Goal: Display MAX (greatest) current result from column which keeps growing

Current issue: I can have all current entries regarded, however a newer, higher value gets ignored.

Attempts to set up : =(MAX(NAME OF COLUMN)) Returns !. =(MAX(Cell_1:Last_cell)) returns all existing values and ignores the new ones.

Also changed: All cells refer to decimal numbers with 2 digits.

What do I have to do to make the formula work?

Frustratingly enough I am working with an Apple template and have copied 1:1 the format that they use…

  • Hope you have already solved this but, if not, can you tell us with which versions of macOS / Numbers have you encountered this problem? I also wonder why you have parentheses before and after the MAX() function? Can you also tell us how you go about setting the formula with MAX(), i.e. how you input =MAX(A) for example? It is normally pretty difficult to select a range of cells within a formula in Numbers unless you do it explicitly.
    – Alper
    Jul 18, 2021 at 14:29
  • At that time the OS was whatever the last version supported b a 2012 MacMini was… I forget which
    – Edd Turner
    Jul 18, 2021 at 14:37

1 Answer 1


I would just give max() the column to work with and it will take the max of all values found. The only danger is if someone adds data further down the column...

See: enter image description here

  • That‘s exactly (part of) the issue. Data in the column is the result of a formula, max () will tell me either what‘s there and ignore newer entries, OR if I complete the column to the end the error readings (exclamation mark) make the formula useless. Or perhaps I could just hide the exclamation marks (how)?
    – Edd Turner
    Oct 21, 2020 at 20:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .