0

Due to the way I have to mount my Mac Mini in my workspace, the Bluetooth reception for the Magic Mouse 2 is terrible - with a link quality of 40% and abrupt decreases to near 0. After buying the IoGear GBU521 and messing around with Bluetooth Explorer, I was able to get my mouse working well on the new adapter. Unfortunately, it doesn't survive reboot, and none of the recommendations I've found have helped.

I came upon posts like the one at Force OS X to use Bluetooth dongle instead of built in controller , where I learned about the setting sudo nvram bluetoothHostControllerSwitchBehavior=always - which according to the documentation does what I want. It did not. Per Force bluetooth usb adapter Mac Catalina, I then disabled System Integrity Protection and tried again. No luck.

I've found that if I toggle the adapter off and on after boot, it comes up just fine. So I thought that it being connected to a hub was a problem in terms of detection order. So I plugged it directly into the Mac Mini. Same thing. Has anyone had any luck in getting their Bluetooth adapter to be the default over the internal one, or possibly disable the internal one?

You must log in to answer this question.

Browse other questions tagged .