0

Hardware: Hackintosh running Mavericks.

Problem: I had a DMG where I store (stored...) stuff I obviously wanted to keep private, so I unchecked the "Save in my keychain" option.

Some weeks ago, beginning to upgrade all my passwords (iPad, phone etc) to something less crackable (like the 6-digit iPhone lock screen) I changed the password of said DMG to a very long new one. I did it following the instructions in Disk Utility.

Yesterday I tried to open it but it said "Try again" a few times until the "Authentication error" window appeared.

I'm very careful with passwords and they are always stored. When I change them I keep the previous one, etc. But I might have screwed this one up because neither password works.

What I did after the change is rename the DMG with a password hint. But when it wouldn't open, I renamed it back to its previous name. Nothing worked.

And since I am thorough with backups too, I updated both backups with the new DMG... so none of them work...

Now the central question: since I did all this on my desktop computer, could I overcome this with some kind of log file, or anything of the sort stored somewhere in my drive? Of course I have full admin access. I took it to my Macbook running Catalina but no luck there either.

Thanks to all !

2
  • Silly question - does your backup keep any history to restore files that become corrupted?
    – bmike
    Oct 20, 2020 at 23:15
  • Oh I don’t think so. On that particular machine I use Carbon CC and set the archiving to “no” because I ran out of space every couple of weeks. Maybe after this I might clear up some space and set it to archive. Thanks for your reply !
    – ipodder
    Oct 21, 2020 at 3:16

1 Answer 1

1

The password used for encrypting the DMG is not stored in a log file or similar. Having full admin access doesn't help you, I'm afraid.

The only real resort is to brute-force the passphrase for the DMG. It seems you have a pretty good idea of what the password is and how long it is - that should make brute-forcing worthwhile to try. I'm assuming here that you made a typo when setting the password or something similar to that.

1
  • Yes, that’s what I thought so I tested some typos too ! Like hitting the keys around the one I meant to...Anyway I thought it weird to make the same typo the first time and when it asks you to repeat or confirm...Can you recommend any brute-force applications that run in Mac....an in poor oldie Mavericks ? It might be my best shot since as you say I know the length, and they were only numbers. Thank you very much for the reply !
    – ipodder
    Oct 21, 2020 at 3:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .