0

So I've been trying to login to servers and MySQL databases recently and it seems that they all come back with either no error or no connection available errors, and I'm wondering how exactly one would go about fixing this.

I'm running MacOS v10.15.5 (19F101) [Catalina] on an iMac with a 3.6 GHz Quad-Core Intel Core i3 processor (pc serial C02D80Y207F1.) I've attempted to login to countless servers and services away from the computer which have worked on other machines as well as try to use and login-to services including ftp, sftp, mysql which have failed on my mac but not the other machines not running Catalina.

I'm hoping to try to get some information on either why this is happening or if this is just a bug on my computer- perhaps a misconfiguration? I've done some googling and I haven't gotten a solid answer or solution on to what to do.

Commands Attempted - That didn't work for me only on a Catalina machine...

ssh (name)@(ip)
ssh (name)@(a record hostname)
ssh (name)@(cname record hostname)
mysql -u example -p pass -h (ip)

I've also tried attempting specified commands with the ports as well.

Edit: SSH -v

sh customer@{ip} -v
OpenSSH_8.1p1, LibreSSL 2.7.3
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 47: Applying options for *
debug1: Connecting to {ip} [{ip}] port 22.
debug1: connect to address {ip} port 22: Operation timed out
ssh: connect to host {ip} port 22: Operation timed out

(Ip being my external server's ip)

~ N.A.

3
  • Related apple.stackexchange.com/questions/400102/…
    – nohillside
    Oct 20 '20 at 19:38
  • @nohillside related title issue and solution does not solve problem
    – Nathanna
    Oct 21 '20 at 1:42
  • I‘m aware of this, it isn‘t a duplicate. In both cases the ssh connection times out though, so future visitors with the same error may find the answer on either of the Q&A‘s
    – nohillside
    Oct 21 '20 at 4:23
2

No, Catalina has not broken the logging into external machines in general. The problem must be local to your machine or your network. I regularly use the commands you mention (ssh and mysql) to connect to external machines from a Mac running Catalina - so in general it works just fine.

I would start by ensuring that you have:

a) a working internet connection (you can browse web sites from the Mac)

b) not running Little Snitch or similar software that blocks outgoing connections

c) not running a firewall or similar on your router or network that blocks your external connections

Then debug by examining exactly what doesn't work:

a) can you ping the IP address of the server you want to connect to?

b) can you ping the host name of the server you want to connect to?

c) can you connect to other ports on the server (for example a web site)?

d) does the server log tell you anything when you try connect?

e) if everything fails, use tcpdump on the Mac and on the server to see network packets going back and forth

From there it should be possible to figure out what the problem with your setup is.

1
  • Ignore my previous comment, it was a wifi setting. I feel stupid now haha! I've closed the question and approved your answer. <3
    – Nathanna
    Oct 20 '20 at 15:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .