Backup is failing on a disk that is near its limit with the error message "not enough space". Weird as Time Machine is supposed to delete old backups as needed to store the new ones.

So, I tried to just reformat using Disk Utility and start fresh. That failed with the error message "disk could not be unmounted".

Next, I tried to make space myself by going into the backup folder and deleted a few of the older dated folders. It took forever to delete a folder via Cmd+Backspace, literally over 30min. :-( I tried instant delete (Cmd+Opt+Backspace) but it wasn't faster and failed on a folder with the the message "items had to be skipped" and the tip to unlock. The folder in question is not listed as locked though. On to the Terminal with "rm -rf folder" which resulted in "permission denied". Sudo of the same command just changed the error message to "operation not permitted".

It's also weird because the deleted folders are still shown in Finder - some processes still running. Only about 30GB on a 500GB disk have been freed so far (20 left initially to 50 now).

The especially troublesome folder I tried the "rm" on stands out as it has different permissions. All folders show "drwxr-xr-x@ 3 root wheel" while this one reads "drwxr-xrwx@ 3 root wheel". Some of the deletion processes are still shown in Finder as ongoing.

How can I just reformat that disk and be done with the nitty gritty? Second best, how can I weed out by hand and delete some of the older backups, getting past the above snags?

System: Catalina 10.15.6

  • Did you reboot the Mac and then try reformatting in Disk Utility as soon as you log in?
    – TJ Luoma
    Oct 20, 2020 at 23:29

4 Answers 4


You can try this method. it has worked in the past. Open your Time Machine backup disk and then Enter Time Machine using the Time Machine icon in the menu bar. Now you should be in Time Machine with a list of the backups. Select one of the backups and then look for a gear icon near the header of the backup you selected. Click on this gear icon and it should have an option to delete that backup. If you open a Time Machine folder you can use the gear icon to delete that folder. Here is what the gear icon looks like:

enter image description here

  • Hi jmh, thanks for the tip. I tried it but there was no delete option when selecting the gear icon, just Open, Get Info, and Restore... see imgur.com/a/nqtIm0G.
    – SeanJ
    Oct 19, 2020 at 7:40

You shouldn't use Finder or terminal's rm to delete Time Machine backups, as they're in a special format.

If you just want to reformat your TM backup drive, just unplug it (because it won't eject/unmount on its own), then plug it back in and erase it with Disk Utility.


None of the above worked for me in the end. Access to the disk with Mac software was so jumbled up that I couldn't sort this out with Finder, Disk Utility, or Terminal. My solution in the end was to circumvent the blockage by formatting it using a blunt Windows tool. It just ignored everything on the old backup disk and erased it. Voila. Not elegant but at least I can use the disk again for a fresh backup.

  • unfortunately, you are right, It doesn't automatically delete old backups. I've had the same problem over and over.
    – Ugur
    Aug 10, 2021 at 17:18

It's storage problem. Go do some research on "How to delate Time machine backup on mac"

Here is my solve:

  1. Get the Time machine disabled.
  2. Use terminal to delate old backups in Time machine.
  • I did search for solutions and the ones mentioned didn't work for me. Backup disk is disconnected but deleting an old backup in the Finder aborts with this error message (imgur.com/a/78flo8n). What's mentioned in the message doesn't work either because the files are not locked. Terminal fails too. I can go to /Backups.backupdb/ but not the subfolders that are visible in Finder. Not even a "sudo ls" works now, even though I saw them earlier when I tried and failed to "rm".
    – SeanJ
    Oct 19, 2020 at 7:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .