0

I used to have just my iMac and I used Spaces to have different apps on different desktops (i.e. Mail on desktop1, iTunes on desktop2, Chrome on desktop3).

I've recently attached another monitor to my iMac and I use Citrix CAG to remote to a Windows PC for work. I share my remote desktop connection across both monitors. To do this, I had to disable the 'Displays have separate Spaces' setting under Mission Control.

Now when I switch between Spaces, the remote desktop connection stays on display on each Space.

Is there any way to avoid this but to keep the Space functionality and to be able to have the remote desktop connection across both monitors?

1

It sounds like you have it set to All Spaces [Desktops].

With the app running & in the correct Space, right click it in the dock & select Options > This Desktop.

enter image description here

For a fuller answer on setting up & using Spaces, see my other related answers at https://superuser.com/a/1187552/347380 or https://apple.stackexchange.com/a/179403/85275

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .