0

My mid-2010 Macbook Pro displayed the question mark on boot. I bought a new hard drive (SSD) thinking the hard drive failed (had a SSD in there).

After replacing the SSD, I still had the same question mark coming up.

I put my original SSD in an external case and successfully booting off USB.

It still did not recognise the internal disk.

After researching the problem, I have since replaced the hard drive cable as this seem a common issue with this machine at this age. This did not fix the issue.

I have been since using the Macbook Pro using my SSD via USB.

One day I booted up and received a message that there was a disk connected that wasn't initialised. Curious, I opened the disk utility to see if my new SSD was recognised. It was! I formatted it and thought my issue had magically resolved itself!

Then the next day it refused to find it again. Then it found it again. And now, ever since it hasn't been able to read the internal disk.

I was hoping to get this working as the machine runs fine, apart from this issue.

Any ideas?

System: OS X Yosemite 10.10.5 Macbook Pro mid-2010 15" 8GB Ram 2.4ghz Intel Core i5

Tried replacing cable Tried using 3 different working hard drives (SSD 500gb, SSD 490GB, HDD 320GB) Tried running on El Capitan using USB Tried zapping PRAM Tried booting in safe mode/select disk boot mode

0

i've experienced the same issue last year. I was instructed to reinstall macOS. And it worked.

You can download the Yosemite & El Capitan bootable installer here:

https://support.apple.com/en-us/HT210717

https://support.apple.com/en-au/HT206886

And create bootable USB: https://support.apple.com/en-us/HT201372

OR through Internet Recovery Mode: https://support.apple.com/en-us/HT201314. Apple have something called EFI: https://en.wikipedia.org/wiki/EFI_system_partition which in your case, i think it might have corrupted. Reinstall macOS would do the trick. You should open your mac and take the 'old SSD' out before reinstall with a new one.

Good luck :)

| improve this answer | |
  • Okay thanks I’ll give that a go. – Geoff Oct 19 at 11:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .