0

I have two external USB drives connected to my 2012 Mac mini, and am finding transfer speeds between the two to be really slow. I need to transfer 38GB of stuff. With rsync, I was getting ~60MBps. Canceled that and moved to Finder and am getting an estimate of ~9 hours to complete the operation.

I did restart the Mac mini hoping it would improve things, but no change. Thoughts on how to improve this?

  • 1
    Perhaps time is being spent by Spotlight indexing 38Gb of data. – lhf Oct 16 at 16:23
  • What's the make, model and type of external? HDD? SSD? Presumably USB? It's certainly true that Finder can be slow, particularly if you have lots of small files, rather than one big one. – benwiggy Oct 16 at 18:45
  • Finder does stuff in addition to raw copy up front. What is wrong with the rsync? – Thorbjørn Ravn Andersen Oct 16 at 20:11
  • What are the drives (manufacturer/model) you've got connected? This mini is capable of USB3, but if your drives are only USB2, then that could be an indication of what's happening. Also, if you are transferring hundreds of thousands, if not millions, of files (and most files are small) that could also be a factor. – IconDaemon Oct 17 at 17:13
0

A method I use to move large numbers of files is the Terminal mv or cp commands. The first command actually moves directories/files from one location to the other, the other just copies the directories/files. This is much quicker than Finder, which adds a tremendous amount of overhead to the process.

Secondly I strongly suggest you go to System Preferences > Spotlight, and add both external drives into the Privacy pane. This stops Spotlight from indexing the files. The drives can be removed from the pane when you're done if you want these drives indexed.

enter image description here

| improve this answer | |
  • rsync works very similar to mv and cp. – Thorbjørn Ravn Andersen Oct 16 at 20:12
  • I'd done this prior to starting my copy, apologies for not mentioning it. Whether Finder, rsync or cp, I'm finding my transfers unacceptably slow :/ – brijazz Oct 17 at 15:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .