I have a MacBook Air which was working fine. Now I have awful network issues since the 10.7.3 update.

My home router is a D-Link DIR-615. I was securing the Wi-Fi network using WEP which worked great on Windows 7/XP/Vista, Ubuntu, iOS, and Mac OS X Lion.

Then I installed the 10.7.3 update on my MacBook Air and the Wi-FI stopped functioning on it. I started to receiving error messages saying, "Select a certificate and enter username and password". I googled this and decided to switch to WPA security since is more secure and though this issue would be resolved. Easily done. No more error messages, internet is working fine everywhere...except on the MacBook Air.

Now when I attempt to connect to Wi-Fi on my MacBook Air, it attempts to connect to my network and connects but gives the error message "Alert: No Internet connection". I checked and it is not getting an IP address. After two minutes or so, it receives a proper IP address, but the internet is not working. Sites simply won't load. When I try to ping my router, I get timeout messages. I have verified that my DNS settings are correct.

Here's what I've already tried:

  • Turning firewall on/off/on again
  • Removed Wi-Fi configuration from System Preferences > Network, and added them again
  • Rebooted my router (several times)
  • Cleared /Library/Preferences/SystemConfiguration folder
  • Installed 10.7.3 combo update

All other Wi-FI devices on my network work with no issues. It's just the MacBook Air that is having this problem.

  • Have you booted your mac into Lion 10.7.2 or another OS to narrow this down to 10.7.3 for certain, or is that more on background information and perhaps something that arrived around the time of the update, but may or may not be related?
    – bmike
    Commented Feb 15, 2012 at 13:55
  • How do I boot it in 10.7.2?
    – Drabuna
    Commented Feb 15, 2012 at 13:57
  • It requires planning and a separate partition. You can install 10.7 onto a spare USB dive or a partition on your existing mac assuming you have space to make a new partition. This leaves your current system safe - then reboot and hold the option key - select the older OS to run tests. There isn't an undo setting, so you just avoid updating to 10.7.3 to do some testing. I'll make a proper answer in a bit - there is more you can do. I was just checking to see if this was really 10.7.3 and at this point, we don't know...
    – bmike
    Commented Feb 15, 2012 at 14:07

6 Answers 6


From what I've seen - this seems to be more a network routing issue than a hardware / link level problem. The first step is to narrow down if it's a network issue or a hardware issue.

In Finder, Shift+Command+G Go to the folder /System/Library/CoreServices and run the two Lion diagnostic tools to assist in narrowing down your problems.

  • Wi-Fi Diagnostics
  • Network Diagnostics

Once you have narrowed down the issue, you can ask a second, more detailed question on how to solve a failing step X in diagnostic Y if you still need help in getting this sorted.

This process was used (as described in the comments) to determine that Little Snitch and the existing firewall were causing the network issues.

  • Network Diagnostics fails at ISP, and no useful advises there. WiFi seems to connect fine, with no issues.
    – Drabuna
    Commented Feb 15, 2012 at 15:13
  • 1
    Bingo - your routing is the problem. Are you familiar dumping the network routing status on the PC (Win or ubuntu) that works and the Mac that doesn't? I use netstat -nr but the Network Utility can dump routing tables so you can compare why the mac isn't getting past the ISP on it's route to the internet.
    – bmike
    Commented Feb 15, 2012 at 15:17
  • Ok, so what i did. I thought about only software that can change my network settings - which was Little Snitch, and I removed it. So now I always get self-assigned IP adress
    – Drabuna
    Commented Feb 15, 2012 at 15:49
  • Yeah, so its working now. I turned firewall on after that, and now I get a correct IP. Thanks all of you for help, it the lamest mac update ever=(
    – Drabuna
    Commented Feb 15, 2012 at 15:56
  • Little Snitch was blocking the DHCP response so your poor lame OS couldn't know what IP address to use. ;-) I've wondered how often Apple considers disabling Little Snitch with every update and making people re-enable it to avoid common problems like this. Do look for a subtle warning that your IP address is self-assigned - that should be in the OS to help you notice this in the future.
    – bmike
    Commented Feb 15, 2012 at 16:03

I've got a fix! - All you do is upgrade to OS X 10.7.4. Did that yesterday and problem solved!! I've been having this issue since I bought my MacBook Air last year. Tried everything and now that I've updated it works fine. Thanks Apple, better late than never, I guess...


I would suggest the following troubleshooting steps:

  • Try booting to the recovery partition on by restarting your machine and holding + R on startup. See if you can connect to your Wi-Fi network from there.

  • Try resetting the PRAM by restarting your machine and holding + alt + P + R until you hear the POST chime twice. See if you can connect to your Wi-Fi network then.

Let me know what your results are and we'll go from there.

  • Tried both, but no result, still no internet.
    – Drabuna
    Commented Feb 15, 2012 at 14:56
  • Unless you have the resources to do this on your own, I would suggest bring your MacBook Air to the Apple Store so they can boot to another OS and test it from there. If it still doesn't work in the external OS, we know it's a hardware issue.
    – Matt Love
    Commented Feb 15, 2012 at 14:58
  • I still have no 802.1x configuration profiles, could it be the reason?
    – Drabuna
    Commented Feb 15, 2012 at 15:03
  • That shouldn't matter. I'd go through and do @bmike's suggestion and then head to the Apple Store if that doesn't show anything.
    – Matt Love
    Commented Feb 15, 2012 at 15:11

Also I'd try removing Bluetooth from your Network preferences - select it from the list then click the - button. (You can easily replace it later if you want/need.)

  • Did it, but no result.
    – Drabuna
    Commented Feb 15, 2012 at 14:56

I did everything and finally reset firewall. I installed 10.7.3 right at the same time my provider had a fault. I thought it was him then saw the 10.7.3 issues. Final fix... Firewall settings!!! Almost got into the black voodoo of terminal. Good luck everyone.


I have read a billion posts everywhere and I haven't see anyone try this. I went into my wireless router (Linksys) with setup and with the DHCP reservation button I made a reservation with my mac address and selected an IP of (there are PCs on my network and an Xbox) my Mac kept getting bucked along with their laptops and the Xbox. My mac is the only machine with a reservation so the PCs and Xbox can randomly choose anything between .100 and .149. Doing any of that crap in network/system pref just fixes the problem for a day if you are lucky, a minute if you are most people. I tried everything and this has actually seemed to work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .