5

I have an android phone and normally use the Google Messages app for sending and receiving SMS.

Yesterday, I used the macOS Messages.app app for the first time to send a friend a link. I guess they have an iPhone, because now when they text me it comes to Messages.app instead of to my phone. I'm assuming this will be the same for all other iOS users.

How do I prevent all Messages.app and iOS Messages users from sending me NON-SMS messages? Thinks I have tried:

  • Closing Messages.app. I still get macOS notifications of messages.
  • In Messages > Preferences… > Accounts > [my email address], untick "Enable this account". Then my friends messages disappear and I never see them at all, at least until I reenable in Messages.app.
  • Looking in System Preferences and on icloud.com and appleid.apple.com to see if there is some setting I can disable—but I've not found anything relevant.
  • Using Apple's Deregister iMessage tool to unregister my mobile number. When I attempted this it gave me the message "Your phone number is not registered with iMessage."

This question was closed as a duplicate of Removing phone number from iMessage, but as noted my phone number is not registered with iMessage, so that question is not relevant.

Am I doomed to never receive SMS from iPhone users ever again?

3
  • @bmike do you want to move your answer to the other Q?
    – nohillside
    Oct 14, 2020 at 10:38
  • I've edited the title, the solution most likely involves changes on the sender side.
    – nohillside
    Oct 15, 2020 at 9:51
  • Messages preferences -> iMessages tab, under 'Enable this account' there is block with heading 'You can be reached for messages at'. What happens if you untick all the options provided there? Oct 19, 2020 at 11:23

1 Answer 1

1

You may not have to do anything except deregister your cellular number from messages.

At that point, if people send you messages to your Apple ID they won’t deliver if you sign out of the app on any remaining Apple OS devices.

1
  • 1
    A good suggestion, but no dice: "Your phone number is not registered with iMessage."
    – cpcallen
    Oct 15, 2020 at 9:29

Not the answer you're looking for? Browse other questions tagged .