1

I have an Arteck HB086 bluetooth keyboard that I bought in the UK. I generally type in American English and MacOS's regional settings are U.S.

Until today, the keyboard worked with US-standard key mappings even though the keys are printed with UK-standard keys. For example, on the UK keyboard the @ is to the right of the colon instead of the single/double-quote button; on a US keyboard, @ is on the numeral 2.

I've re-paired, re-booted, etc. In other words, my system settings no longer seem to override the physical keyboard settings. The keys are still showing up as the UK mappings in both MacOS and Windows (I'm dual-boot). Again, I changed nothing today; something must have updated and now it doesn't work and I can no longer effectively type. Any help is appreciated.

3
  • Have you tried a safe boot? Sounds like perhaps a cache issue. Commented Oct 13, 2020 at 22:08
  • Have you tried the 're-recognise' app in Keyboard prefs, "Change Keyboard type"? It sounds like it's being recognised as UK ISO not ANSI [only UK PCs have @ on the right, UK Macs have it above 2, like US]. Also check what character you get on the key left of number 1.
    – Tetsujin
    Commented Oct 14, 2020 at 8:08
  • I will try safe boot, thanks for the suggestion. I have indeed tried re-recognize and selected ANSI; agree that it seems to be operating as UK ISO.
    – ElBel
    Commented Oct 14, 2020 at 9:11

1 Answer 1

0

Okay, I ran into the same problem today and think I found a fix (leaving this out for anybody who stumbles into this thread later).

The problem was to do with the different modes on the keyboard. My keyboard, under q, w, and e (in blue, fn key), has iOS, Android, and Win as optional buttons to press. It seems the keyboard had defaulted to the wrong version, possibly due to running out of battery. I struggled with this for a few hours, before it turned out that pressing Fn+e (Win) resulted in the keyboard returning to its UK layout and behaving normally. I believe it was on the iOS setting, which defaults to a US keyboard for some bizarre reason.

Hope this helps (although I realise this is now long in the past).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .