2

I'm using Safari 5.1.3 on Lion.

Each time I click the RSS icon in the address bar (or directly visit the feed), Safari will report can't open page, saying operation not permitted with the NSPOSIXErrorDomain: 1 error. For other web sites, Safari works fine.

I have no 3rd party firewall installed on my system. I also tried to disable the firewall in system settings but still getting the same error.

As I use Google Reader, I've once installed the "Add To Google Reader" extension from Apple's site, but it didn't work for me.

  • What exact version of safari are you running ? – Nils Munch Feb 15 '12 at 7:58
  • I'm using Safari 5.1.3 on Lion. – cyfdecyf Feb 15 '12 at 8:56
  • Can you copy the URL and paste it into Google Reader? – Timothy Mueller-Harder Feb 15 '12 at 21:58
  • Yes. Currently I just copy the URL and paste it into Google Reader. But this error is annoying. – cyfdecyf Feb 16 '12 at 4:18
2

Based on the error message, I tried the following command and solved the problem:

chown -R username: ~/Library/Safari

So I guess there are some files or directories which does not belong to me. It's weird how could this happen because I never touched that directory manually before.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .