1

I was trying to update my iPhone X (GSM) from iOS 12.3.1 to iOS 14.0.1

The following steps was carried:

1- Downloading the latest firmware ipsw (size 4.61 GB) from iPhone10,3,iPhone10,6_14.0.1_18A393_Restore.ipsw from ipsw.me

2- Downloading the latest iTunes on my Windows 10 PC

3- Connecting the iPhone by an original USB cable to my PC

4- Locating my iPhone and pressing "Shift" button from my keyboard and pressing on the Update from iTunes

5- Selected the ipsw which was previously downloaded.

6- During in the middle of the update, an error came out with a code # 14.

7- My iPhone got stuck permanently on the iTunes logo

8- Tried for several times to exit the Recovery Mode by Pressing and quickly release the Volume Up button. Press and quickly release the Volume Down button. Then, press and hold the Side button. it just keep restarting and getting back into the Recovery Mode.

9- Downloaded couple of software's "Tenorshare ReiBoot Pro" and "3uTools" to force exit Recovery Mode, no good results.

The problem here is happening because I guess that I have tried to install the updates although there was no enough storage on my iPhone.

If there is anyway to delete large files in order to free space of my iPhone (while it is in Recovery Mode" it would be much appreciated.

Or

If there is a way to update the iPhone to any iOS that has a small ipsw size would help on this issue, bare in mind downgrading or using OTA (Over the Air) firmwares to be directly installed on my iPhone by a PC.

Note:

Thinking outside the box:

If there is a way to connect the iPhone to any operating system i.e. Linux and have it connected there by entering the file explorer in order to delete some large files would help, need some experiments please.

4
  • You might want to try the trial version of iExplorer to see if you can extract your photos and videos to make room. It can also extract text messages and image/video media associated with them. I'd give this a try. It is a powerful application, and it has really helped me out in situations which would have resulted in total data loss when a wipe & reload of iOS seemed to be the only option. Disclaimer: I have no association with Macroplant LLC, financial or otherwise: I'm a satisfied user of iExplorer. – IconDaemon Oct 11 '20 at 14:48
  • If it failed halfway through the update & are now in Recovery, essentially you are now reliant on the backup you failed to make. You had two opportunities, one every time you charge it, to iCloud & another right before you ran the update, to the computer. Apparently you ignored both opportunities… drivesavers might be your last hope. – Tetsujin Oct 12 '20 at 15:27
  • @Tetsujin You mean this drivesaversdatarecovery.com/data-recovery-services/… ? – Tak Jan 14 at 14:09
  • Yes, or national equivalent – Tetsujin Jan 14 at 15:31
0

I have an idea.

  1. get off the nand flash from the mainboard.
  2. copy all nand flash data to a large one.
  3. solder the large nand flash with data to the mainboard.
  4. update new IOS with itunes.

Because changing a new larger nand flash in China is a very common thing. And there is a nand data mirroring tech in 2016 on Iphone 5C. So I think Combine these two technologies may be can solved this problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .