0

I'll often save links from Chrome to my desktop or Finder, simply by dragging the URL from the address bar to wherever I want to save the shortcut to.

But all of a sudden it won't let me anymore. I think I used to get the green + icon showing when I'd be dragging it, but now I just get the website name and then it just disappears when I unclick my mouse:

enter image description here

I've just tried doing the same in Safari and that won't work either (although not sure if it normally would as I never use that browser).

I've tried Googling the answer but can't seem to find anyone else with the same problem, has anyone else had this?

  • 1
    I just tested in Catalina (10.15.7) and I can drag URLs from the address bar in Safari, Edge, Firefox, and Chrome (latest version of all mentioned). What version of macOS are you running? Versions of browsers? Try creating a new user (as a test) and see if it works in that account. But to be candid, that's a rather peculiar way of bookmarking things...doesn't your desktop get super crowded? – Allan Oct 11 at 7:04
  • @Allan okay so I finally found the solution to the problem... turned out I just needed to restart my machine! somehow it took about 3 days for that to occur to me! – pealo86 Oct 11 at 20:40

You must log in to answer this question.

Browse other questions tagged .