5

Note: I only want to download it, not install it on the 2011!

The App store doesn't let me download it, but I don't want to install it, I just want to download it and create an USB installer so I can restore my other Mac.

How can I do this?

9

You can use Dosdude1's Catalina patcher to download the official Catalina installer from Apple's servers.

Disclaimer: I'm not a fan of bodging macOS to work on unsupported platforms, especially for "production" machines. However, if you're looking to tinker and this is something to experiment with to learn, I say have at it. If you need the latest OS for work, get a machine that supports it.

Basically, what you're going to do is trick macOS and ultimately Apple's servers into believing that your machine is capable of running Catalina so it will download.

When you run the Patcher, make sure you uncheck "Auto-apply Post Install Patches" found in the Options menu." This is because you're not installing Catalina onto this Mac; all you want to do is get the installer so you can create the USB Installer.

Once you will get to a screen where you can either browse for an installer or download a copy, select the download option.

Catalina Patcher Install Screen

Download the DMG, it will be approximately 7GB. From there, you can make your offline installer. The Terminal command is as follows:

sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/Catalina --nointeraction

If this worked out for you, I encourage you to buy him a coffee or a beer (or maybe even dinner) by sending a donation his way (I'm not affiliated, I just appreciate people's hard work). You'll find the "donate" link on the software download page.

| improve this answer | |
  • 2
    To add to Allan's answer, since you are just wanting to create an USB Installer, watch the Tutorial Video starting at about the 6 minute mark. youtu.be/wxFzZWqoCng?t=358 – user3439894 Oct 10 at 16:10
  • Thanks, I just tried it and the download failed in the middle. Also found gibMacOS that apparently does the same, although it's taking forever to download. Will try this, thanks! – Petruza Oct 10 at 16:45
  • 1
    @Petruza Downloads failing halfway through isn't unusual in this case. The slightest hickup in you internet connection may cause this. In my experience the download process doesn't handle network hiccups very well and easily aborts in stead of retrying and continuing. You may to try a couple of time before it succeeds. – Tonny Oct 11 at 15:48
  • @Tonny, And that is why I would not use this method and instead use a virtual machine running an appropriate version of the OS that will allow the download thru normal Apple methods, which will typically recover from a network hiccup. – user3439894 Oct 11 at 16:25
  • I haven't tried it...can you run a version of macOS that's unsupported natively on a host running VM software (Parallels, VBox, VMware). Can you run Mojave/Catalina in a VBox VM that's on a Sierra host? (I don't have the hardware to try it out). – Allan Oct 11 at 16:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .