34

How can i remove the "Eject" icon from the menubar?

It's an icon that starts on login. It ejects all mounted disks (dmg/usb/etc...).

enter image description here

  • 2
    Possible duplicate of apple.stackexchange.com/questions/31953/… – Max Ried Feb 14 '12 at 11:36
  • 3
    I'm inclined to leave this here. The wording is different and one is general and the other specific. Having two or three good questions that are distinct enough in wording will help a greater number of people searching for questions to find an answer here. Unless there are other exact matches, these two questions are fine for the site. – bmike Feb 15 '12 at 15:46
  • 1
    I definitely wouldn't have found the other question. – drewish Nov 3 '12 at 0:10
  • I guess I know what commonly causes this: If you attach a non-Apple keyboard, the Eject menu comes for rescue as a replacement for the missing keyboard Eject key. – Max Ried Oct 10 '15 at 9:00
  • In my experience, this icon only appears when you have a super drive attached. Remove it, and it goes away. Is this not happening for you? – oemb1905 Jan 6 '18 at 14:18
75

Hold and drag it away from the menubar.

  • 1
    You can also move them. Notice that this does not have to work with every application. e.g. Dropbox does not honor the key, while iStat Menu does it. On the other hand you remove Spotlight search using this trick. – Max Ried Feb 14 '12 at 11:41
  • 1
    @bot47 In the future, if you already know it's a duplicate, please flag it for moderator attention to have it closed, and don't answer it. There's no point in duplicating information all over the place. – slhck Feb 14 '12 at 11:53
  • I did flag and answer it – Max Ried Feb 14 '12 at 11:53
  • Thank you for the flags - in general we do like to close exact duplicates but this is more of a special case. The flags were helpful to make sure we want both questions here. – bmike Feb 15 '12 at 16:01
  • I just tried this tip and I can move the icon from left to right but I can't remove it. (using Mavericks 10.9.2). – politicus Apr 1 '14 at 12:03
0

If you have Bartender installed, use Shift+ and drag the icon away from the menubar.

  • 2
    I just tried. Command alone is working. Maybe you have some tweaking tools installed? – Max Ried May 4 '16 at 14:46
  • 1
    Ooops. True, I have Bartender installed. – WillCroPoint May 4 '16 at 14:47

You must log in to answer this question.

protected by bmike Jan 6 '18 at 2:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .