I am trying to delete a friend's old email address so it doesn't automatically pop up when I enter his name while addressing an email. I have removed it manually from the address book, but it still shows up in Mail.

How do I stop this happening?

  • 1
    Recently, the option to remove from previous recipients list is gone. Address is not in Contacts. No evident way to remove old address. Can I get the option to remove to re-appear? – user187344 Jun 6 '16 at 23:15
  • I'm on 10.11. I have an address with a typo in the domain, which appears in auto-complete every time. This address is not in Contacts, nor in Previous Recipients. Is there any way to get rid of it? This is horribly annoying... – marc.guenther Nov 7 '16 at 11:15
  1. Fire up a "New Message" from the File menu (or use command + N)
  2. Begin typing the address
  3. When Mail starts to complete the address you want, hit the Return key to tell Mail to go ahead and auto-complete the address
  4. Hover the mouse pointer over the address; a blue arrow will show up on the right hand side.
  5. Click on the arrow, which brings up a drop-down menu. The menu contains several options, one of which is "Remove address." Click it, and it will remove the address from auto-complete.
|improve this answer|||||
  • 5
    @Peggy Please can you accept this answer when it resolves your problem! – Tim Feb 14 '12 at 12:36
  • 2
    @Peggy, it's important to accept answers that work for you. It's what makes this system work. Please read about accepting answers. – SSteve Feb 16 '12 at 17:56
  • The "Remove address" option simply removes the address from the recipients of the current e-mail. What you want (if it is present) is the "Remove from Previous Recipients List" option. If it is not present, the auto-complete address is coming from your Contacts (Address Book) and must be removed from there. – Alex Dupuy Aug 22 '12 at 12:18
  • @AlexDupuy that is not exactly correct, at least in 10.6.8. "Remove from Previous Recipients" only shows up as an option if the person was never in your address book to begin with. In either case, "Remove Address" is present and is the permanent solution. – soxman Aug 26 '12 at 5:56
  • Does not work for me (macOS 10.12.6). The address still appears on auto-complete. The “Previous Recipients” window fixed my problem. – Marcus Nov 23 '18 at 7:10

Under Mail's "Window" menu select "Previous Recipients" and you can delete any address you don't want.

|improve this answer|||||
  • Note that this menu option was added in Lion, and is not present in (Snow) Leopard or earlier releases. See support.apple.com/kb/PH4891?viewlocale=en_US – Alex Dupuy Aug 22 '12 at 12:19
  • This is a great solution. In that window, you can sort by whether people are in your contacts. You can then select all the ones who aren’t, and clean up your entire Previous Recipients list that way. – user11633 Jul 10 '16 at 14:58

When the suggestion appears, just use the navigation to reach it then press delete on it, that's it.

|improve this answer|||||

I just wanted to add a note here that it is apparently not possible to delete previous recipients on iOS.

|improve this answer|||||

This only works to effectively "hide" the previous recipient from the previous recipients list on your phone. Apple still keeps a file with all your previous recipients in iCloud. When you completely "Erase all Content and Settings" and set up as a new phone, then sign in to iCloud all the previous recipients are restored.

In other words you have to do this painful process of deleting every previous recipient you don't want in the list individually every time you get a new iPhone/iPad or otherwise want to start from scratch and do a complete erase on your current device, even if you set up as a new device. This is easily replicated and proved. In fact I intend to go to an Apple Shop soon to demonstrate and question the behaviour and whether it's possible for Apple to delete information about who I've emailed.

The inconvenience is one thing but I'm more concerned about the privacy implications that Apple keeps a "previous recipients" master file that you don't have access to and whose entries can't be deleted. A similar situation exists for Mail on OS X though it appears to be a different previous recipients master file. That is, every time I do a clean install of OS X or even set up a new account and log in to iCloud, the Mail app shows a bunch of previous email recipients that aren't present in any email message!

Fantastic information for the government along with all your other metadata.

|improve this answer|||||

To delete a person’s old email address, in Mail go to the ‘Window’ drop down menu (just before 'Help') and click ‘Previous Recipients’.

Then click on the old email address you want deleted and click the ‘Remove from List’ button.

|improve this answer|||||
  • Thank you Joel. Simple instruction which does work. I have spent hours trying to get rid of an unwanted email address. – user191551 Jul 10 '16 at 14:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .