0

I am using a mid-2015 MBP which is running MacOS Mojave 10.14.6.

Whenever I am typing a "." (dot) it is printing "\." (backslash + dot). Now I have to manually remove this backslash every time. (It can be little frustrating while coding)

All other keys are working perfectly fine.

I checked all the possible keyboard settings and googled almost all possible phrases to find a solution/hint but couldn't find anything helpful. Tried restarting the system twice.

Faced issue while logging back in as I forgot a backslash is also being printed along with the "dot" and my password contains a dot.

PS - My MBP has crashed a couple of times in last 1-2 days. I also checked the answer here but it seems to be a different problem hence asking a different question here.

  • Try an external keyboard (doesn’t have to be from Apple). If it works ok, the internal one could be damaged. – Tom Gewecke Oct 7 at 21:40
  • @TomGewecke USB Ports are not working and I do not have a bluetooth keyboard. Anyways I followed the instruction to reset NVRAM from here and luckily it worked. Still sometimes I see that weird behaviour. – Rishi Oct 9 at 13:47

You must log in to answer this question.

Browse other questions tagged .