1

I just started having this issue with my Mid-2014 15" Macbook Pro with Retina display, and I've tried refreshing a few processes and did a factory reset, but am still having the problem appear.

I've tried to disable the SIP to disable the Thunderbolt extensions, but it looks like that wasn't a thing until a later OS. Is there a way to circumvent this without having to go to Catalina? I'd prefer not to so I don't lose access to certain 32-bit applications, but if there are no other options, then there's not a whole lot I can do.

Thanks for the advice/help in advance!

Edit: I have tried the following:
-moved /System/Library/Extensions/AppleThunderboltNHI.kext to the desktop, which made a copy
-unlocked and logged in as root user
-went into terminal and used
kextunload /System/Library/Extensions/AppleThunderboltNHI.kext
-locked the root user back up and rebooted

Edit 2: Did the following:

  • Opened Terminal on normal user login, used
    sudo kextcache -system-prelinked-kernel
  • Entered password to confirm change, then:
    sudo kextcache -system-caches
  • Rebooted.
  • 2
    SIP was introduced in Mac OS 10.11 El Capitan. You should be able to do this. As the quoted article says, "...So if you disable (move out of /System/Library/Extensions) AppleThunderboltNHI.kext driver then reboot..." Try that and if it does not work, add what you did (in detail) to your original question. – Steve Chambers Oct 6 at 23:47
  • Added what I did, still getting the lit black screen to shut down. I should've just hit Move to Trash, maybe, but my brain saw 'disable' and panicked for some reason. – shiningbind Oct 7 at 1:07
  • 1
    You may need to rebuild the kernel cache. After moving the kext to your desktop and deleting the original, open the Terminal and run sudo kextcache -system-prelinked-kernel && sudo kextcache -system-caches. Then reboot and see what happens. – Wowfunhappy Oct 7 at 1:31
  • Also, I would encourage upgrading at least one version to El Capitan; Yosemite is a particularly buggy mess. (El Capitan comes with SIP, but it can easily be disabled. And no, disabling SIP is not a security risk compared to running an OS that doesn't have SIP in the first place.) – Wowfunhappy Oct 7 at 1:33
  • 1
    If you've removed the kext and rebuilt the cache, I would conclude that the problem is something else. – Wowfunhappy Oct 7 at 2:58
1

You don't need to disable SIP to remove the extensions. All you'll need is an Admin account for the Finder popup when you move the extensions out of the System folder.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .