I was trying to factory reset my 12” MacBook A1534.

Went as instructed into recovery mode and clicked “erase” for the internal disk. While I erased I went with the default set, “APFS format.” The computer restarted and I was left with a black screen and the flashing logo of a folder and a question mark. I booted back into internet recovery mode (command+R) into disk utility and I see that I am left with a drive named, “APPLE SSD AP0256J Media.” I then learned that I might need to reinstall El Capitan but it wouldn’t let me because it’s saying that the drive needs to be journaled. My main issue here is,

Every time I try to journal whether it’s by partitioning, erasing, or using the command prompt, disk utility freezes and the bar doesn’t load at all. It then brings me back to the black screen with the folder and question mark. It lets me choose any other format like ExFat except journal which is the one I need.

I also ran diskutil list and I see that I don’t have an synthesized drive anymore, I do not have the Macintosh HD, Preboot, Recovery, VM.

I’m not very experienced with this stuff.

Can someone please help. Id hate to toss this computer and “get a new hard drive” as others have told me, on this Mac the SSD is soldiered on the board.

enter image description here

enter image description here

enter image description here

enter image description here

EDIT: I am able to formate using exFat successfully but I get this message. I’ve tried enabling journaling via Terminal and it just freezes up when I do anything involving journaling. enter image description here

EDIT #2: I just tried using the (Command - Option - R) and Catalina came up, I reformatted into APFS, while loading it said it was journaling. Then the screen went black showing me a folder with a question mark. I went back into the Catalina recovery and it’s saying it is in Mac OS Extended now, but it’s not journaled and it won’t mount so I cant install catalina. I don’t believe SSD is bad because smart status says verified. enter image description here

  • Did you let the install finish finish completely? This is a common symptom if you restart before it finished and many people do because people assume it's hung up at the end because it says "100%" and appears to be doing nothing. Allow it to reboot itself. If you do restart it manually, you will have to reinstall
    – Allan
    Oct 6, 2020 at 15:06
  • @Allan yeah I restarted when I first did it because the bar was not moving it was stuck at 24% of the Apple logo I left it for about 2 hours. Could this really take longer than that? Also, could it be an issue because the disk is full and doesn’t have any space to install OSX or is it just supposed to be like that?
    – Clown
    Oct 6, 2020 at 15:09
  • It can. I've left it overnight in some cases. Others, I opted to restart from the beginning. If it stuck at 24% however, there was an issue. Looking at your 2nd edit, I would look at using some more robust tools than the built in "Verified" for SMART status. It's like the check engine light in your car - it's only correct when something is wrong enough to trip a sensor. Verified only means it passed the limited tests - not that it's failing. Look at DiskDrill and boot macOS from an external drive to diagnose.
    – Allan
    Oct 6, 2020 at 15:28

1 Answer 1


It's normal to not have a Macintosh HD volume and other volumes after you've erased the disk since the disk is now empty without an operating system installed.

It's normal to have many little ‘disk image’ disks show up in diskutil list since that's how the Recovery environment works (diskutil list shows 20 disk partitions, I only know 3, what are the rest?).

It's not normal to be unable to erase a disk to enable journaling. However, journaling is only an option on HFS formatted disks, and you should be using APFS.

In Disk Utility, with the top-level disk selected, Erase, then enter a name like Macintosh HD, choose APFS as the format and choose GUID Partition Map for scheme. Once the disk is erased, exit Disk Utility (don't reboot, just close the app) and choose Install macOS from the recovery dialog.

  • For instance I tried to erase the disk using Mac OS Extended (Journaled) and I am currently still on the disk utility screen frozen. The only way out is just to shut off the computer. Also for some reason I can’t find the APFS option. The rest of the partitions are all untitled and range from 1MB-100MB.
    – Clown
    Oct 5, 2020 at 21:41
  • El Capitan does not support APFS at all. For El Cap, you want Mac OS Extended (Journaled) as the volume format. Oct 6, 2020 at 0:30
  • Yeah. I’m having a bit of trouble journaling. Any suggestions?
    – Clown
    Oct 6, 2020 at 3:08
  • I don't know why it'd hang trying to reformat. One thing you could try is restarting with Command-Option-R to load the newest compatible version of recovery (see HT204904) -- that should get you the Catalina version of recovery, which will know how to format in APFS (and can then install Catalina if you want). Alternately, the Catalina recovery might be able to format it in "Mac OS Extended (Journaled)", and then you could restart back to El Cap recovery and install that. Oct 6, 2020 at 4:26
  • @GordonDavisson could this possibly be because the SSD is full? It says 0 Free space for some reason.
    – Clown
    Oct 6, 2020 at 12:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .