1

I have bluetooth headphones I use on my macbook pro (2017 13", 10.15.6). I don't recall this problem happening before, but over the course of the past couple of weeks (very rough approx - clould be less, could be more) I've noticed that I often hear the system alert sounds through the internal speakers. For instance, right now, if I play music, it comes out of my headphones properly. But if I send an email, the email sent alert sound comes out of my internal speakers.

For what it is worth, if I manually switch the sound to internal speakers (while the bluetooth headphones are connected), all the sounds comes from internal speakers. And then if I switch it back to the bluetooth headphones, I am back where I started (with music coming from headphones, but email sent and calendar alert sounds coming from internal speakers).

Is this a configuration option (i.e. allowing special sounds to bypass the sound output settings), or is something wrong?

0

In System Preferences > Sound you can control the sound output from the "Output" tab. This is the same setting you can change from the speaker icon in the menu bar. This sets the audio device to be used for ordinary sound output such as music, games, etc.

However, in System Preferences > Sound you'll also find a tab named "Sound Effects". Here you can set a separate audio device to be used for sound effects such as email alerts, etc.

Note the setting "Play sound effects through:" - usually you will find it set to "Selected sound output device", but if you set it explicitly to the internal audio device, you'll get the experience you're describing.

1
  • Ah - perfect. Curious how it got changed, as I certainly never did that myself. I wonder if the zoom app might have done this, as it seems to be rather persnickety about the audio settings and often has to ask for my password to twiddle with them at startup.
    – Doug
    Oct 5 '20 at 22:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .