1

I formatted the drive on the MacBook Pro because my sister used to own it (she bought it off of ebay) and it had a lot on it. When I started it back up, it booted into OS X utilities and when I tried reinstalling the OS which was El Capitan, it gave me the prompt to sign in to my apple id. I signed in but it gave me the error: This item is temporarily unavailable. Please try again later.

Afterwards I have tried many different things, none of which have worked, including:

  • Signing into iCloud on the device before trying to reinstall the OS
  • Changing the date around
  • Created a USB boot drive with El Capitan and Yosemite and trying to boot off of those. The MacBook did not recognize the USB drive. The drive was in GPT.
  • I cleared pram before trying USB boot drive too
  • And since the MacBook Pro is from 2009, internet recovery mode did not work either.
1

I figured it out. I just created a USB boot drive with Mavericks and that showed up. I waited a while and eventually it worked. From there I just downloaded an upgrade for El Capitan and I was all set.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .