I just updated my macOS to 10.15.7. I notice that now when I hover over the window's green maximize button for about a second it now presents me with a menu, which I have to click to dismiss. Is there any way to change this behavior so it no longer automatically displays a menu when I happen to hover over the maximize button for too long? I suspect it will get in my way far more often than it will be useful to me.

The menu has four options when I view it on my secondary display:

  • Enter Full Screen
  • Tile Window to Left of Screen
  • Tile Window to Right of Screen
  • Move to Built-in Retina Display

Maximize button hover menu

  • As a side note: what's the official name for the green button? A cursory Google search didn't provide me with any definitive answers. – M. Justin Sep 30 '20 at 21:15
  • 1
    Thank you for documenting this! It’s called the maximize button. itunes.apple.com/WebObjects/MZStore.woa/wa/… – bmike Sep 30 '20 at 21:21
  • @bmike Thanks! I see the term defined in that book, and I've updated the terminology in my answer accordingly. – M. Justin Sep 30 '20 at 22:04
  • 1
    @bmike Huh, I could have sworn I read it was called the Zoom button! I wonder, I've mainly looked at older docs, do you know if the name changed? – Wowfunhappy Oct 1 '20 at 3:48
  • 2
    @Wowfunhappy — It's listed under both in the linked Apple Style Guide. "maximize button — The rightmost (green) button of the three window controls at the lft of the title bar. Users click this button to go full screen, or Option-click it to maximize the window". "zoom button — The rightmost button of the three window controls at the left of the title bar." – M. Justin Oct 1 '20 at 3:56

You must log in to answer this question.

Browse other questions tagged .