5

UPDATE: Apple has now issued a supplemental update that's fixed this issue for me (and presumably the other issues caused by the original Safari 14 update).

As of a couple of weeks ago, none of my App Store apps will update (2015 MBP 15", Mojave 10.14.6). The Update button just spins for a bit, then stops. If I uninstall the app, I can reinstall it, but subsequent updates still fail.

The only abnormal Console output after I click Update appears to be:

AMSURLRequest: Failed to fetch GUID schemes from bag

I've signed out/in, deleted App Store caches from ~/Library/Caches and ~/Library/Containers, temp files from $TMPDIR../C/com.apple.appstore/, and even reinstalled Mojave, but the issue persists.

I see the same behaviour with the MAS in both the user and admin accounts on my system, although of course they're both logged into the MAS with the same Apple ID.

Any other ideas? (I'm not in a position to install Catalina at present, whether that's likely to fix it or not.)

Possibly-related observation: I tend to move 3rd-party (i.e. non-Apple) apps into a sub-folder of /Applications after I've installed them. This has never fazed the App Store before, but now as soon as I move an app away from /Applications, the App Store shows me the 'download' icon rather than the Open button, as if it thinks the app has been uninstalled. (Yet, it still shows me update notifications for that app, and for others that I've previously moved.)

8
  • 2
    Does this answer your question? Mac App Store: Downloads just don't start (Mojave)
    – IconDaemon
    Sep 30 '20 at 18:36
  • Sadly not. I've tried everything there that involves killing any processes (by dint of reinstalling Mojave), and the fact that I can download every app, just not update them afterwards, isn't really addressed by any of those answers.
    – calum_b
    Sep 30 '20 at 22:31
  • 1
    Same problem here. My brother is also experiencing it on his laptop running Mojave. And I’ve seen some mentions of it on Twitter. That suggests it’s an App Store issue. I think we have to wait for Apple to fix it.
    – Jonesy
    Oct 1 '20 at 6:35
  • 1
    Seriously, reinstall Mojave on top or grab the combo updater @Jonesy - it’s likely some updates that were delta messed things up in several ways. The reinstall doesn’t delete your files or data, just fixes the system.
    – bmike
    Oct 1 '20 at 13:13
  • @bmike Tried reinstalling Mojave on both my Macs. No luck. App Store updates still fail.
    – Jonesy
    Oct 1 '20 at 18:39
2

I have been having the same issue on Mojave 10.14.6 with trying to update apps from the App Store, with installs of new apps (including if you delete an app you're having trouble updating, then just install it again) working fine.

For reference of others reading this, most of my Apps (certainly the ones affected) are just in /Applications so that's not part of the cause.

Probable Cause

Searching around, I found that the community has identified an issue:

https://mrmacintosh.com/mojave-2020-005-security-update-causing-major-problems-updated/

The TLDR version is that:

  • if you installed Safari 14
  • then the most recent Security Update

in that order (Safari 14 first), then you tend to encounter the issue; if you installed the Security Update first, then Safari 14, you're likely to be ok.

Checking if you're affected

The last part of the TLDR is that you can check if you're encountering the same issue by running the following in the Terminal:

softwareupdate -l

If you are, you'll see the following output:

objc[5711]: Class AMSupportURLConnectionDelegate is implemented in both /System/Library/PrivateFrameworks/EmbeddedOSInstall.framework/Versions/A/EmbeddedOSInstall (0x108f37c58) and /System/Library/PrivateFrameworks/OSPersonalization.framework/Versions/A/OSPersonalization (0x108d9a358). One of the two will be used. Which one is undefined.

So what do I do now?

It seems Apple has pulled the updates, so we can hope there will be some fix and revised update for everyone who hasn't installed the updates yet soon 🤞🏻.

The current solutions (detailed on the above link), other than waiting, are that you can do a full re-install of macOS 10.14.6 - over the top, and then go from there.

Installing Catalina is another option, though that may not solve all issues, especially as the latest Catalina patch is also causing issues for some: https://mrmacintosh.com/catalina-10-15-7-update-accountsd-using-400-if-using-icloud-mail/

I'd read and keep an eye on the above link as it gets updated with latest best practice ways to resolve this, and when Apple release an update that resolves things - though it's probably best to wait and see the reaction to that, when it does appear.

Hope this helps!

UPDATE: (1st Oct 2020 13:39 UTC)

Just tried again offhand and now all the updates installed. I recall some server-backend issue like this before a few months ago.

Still doesn't get around the other issues mentioned in the above link, but at least app-updates now install.

Also, thanks to @bmike for the link below in the comments and his separate reply - anyone in future coming here, please check those out.

UPDATE: (2nd Oct 2020 10:11 UTC)

...And the problem is back. Today updates again won't install.

I guess just going to play the waiting game for a bit longer and see what happens.

8
  • 1
    I love me some sweet Mr. Macintosh links and hard hitting details. Here is an older question you might add here with some general advice. apple.stackexchange.com/questions/345857/…
    – bmike
    Oct 1 '20 at 13:06
  • Unfortunately, this did not work for me on either of my Macs. I reinstalled Mojave 10.14.6 on both Macs, but I did not install either Safari or the security update (both of which Apple have now pulled). App Store apps are still failing to update.
    – Jonesy
    Oct 1 '20 at 18:38
  • Same here. As I mentioned in my original question, I'd already tried to solve this by reinstalling Mojave.
    – calum_b
    Oct 1 '20 at 22:03
  • For the record, I am seeing the softwareupdate error mentioned on the command line, so I guess that's what's hitting me.
    – calum_b
    Oct 1 '20 at 22:08
  • We had one of three machines log that error and still work to download apps. The other two needed a reinstall of 18G03 and all three are back working. Might be two things affecting this - hard to tell as I have no broken Macs anymore to poke at.
    – bmike
    Oct 1 '20 at 22:26
0

I would use Safari to download the full OS installer, we have used that to fix many of the recent issues with accountsd and recent updates not applying well.

The above link is easier for me than messing with recovery mode if your Macis working well enough to get the installer into /Applications and run it.

Once that’s done, look over this older post on general failures if you are sure your Mojave is correctly patched and installed.

As a last resort, I would install Mojave on to an external USB drive. Then when I set up a new account there, I can test a clean install on to a clean OS to be sure it’s not some network issue or account issue.

Or you could head into the console log to see what error messages are present and validate your Account and multi factor approvals are not blocking a sign in.

4
  • As I noted in my original question, I've already done a full reinstall of Mojave, which didn't help, and reinstalled all the patches that were subsequently offered.
    – calum_b
    Oct 1 '20 at 22:05
  • Understood @calum_b if you’re on 18G103 then you’ll have to dig into the logs. Let me see if I can find my answer using console to search for App Store error logs and further non-quick fixes.
    – bmike
    Oct 1 '20 at 22:21
  • I’m guessing you didn’t do a clean install of Mojave onto a new drive? The linked answer might be easier to accomplish if you spot an error on the existing Mac @calum_b
    – bmike
    Oct 1 '20 at 22:24
  • Apple has now provided a supplemental update that's fixed this issue for me.
    – calum_b
    Oct 2 '20 at 10:49
0

The macOS 10.14.6 Supplemental Update issued on October 1st 2020 has solved this issue for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .