I attempted to start a Time Machine backup but the backup failed due to insufficient space. I now have a useless 60 GB .inProgress file that's eating into my already limited storage space.

For a seemingly easily-achieved problem, there are few resources online for this. A pre-Catalina article from 2018 suggests using tmutil delete /path, as do these Ask Different answers. All of these answers are also pre-Catalina.*

With such consensus of answers I tried sudo tmutil /path/backup.inProgress but received a return message of "Invalid deletion target (error 22)" and "Total Deleted: 0B"

$ sudo tmutil delete /Volumes/XXXX/Backups.backupdb/XXXX/2020-09-30-004400.inProgress
/Volumes/XXXX/Backups.backupdb/XXXX/2020-09-30-004400.inProgress: Invalid deletion target (error 22)
Total deleted: 0B

Also, when I run tmutil listbackups Terminal only prints completed backups (as the manual indicates should be the case).

How can I safely delete the 60 GB .inProgress file?

*This answer suggests simply dragging the .inProgress file into the Trash – though from personal experience I know this is wrong and leads to problems – namely a perpetually stuck Time Machine and an impossible to empty Trash.

  • I'm on Mojave and I have no problem deleting them with tmutil. Try ejecting the disk, restarting your computer, running another Time Machine backup, or possibly running First Aid on the disk. Commented Oct 1, 2020 at 22:46
  • Don’t have it with me to try again but I’ve done most of the above. If I remember correctly I was able to delete with tmutil when on High Sierra. I think it’s a Catalina change @At0mic
    – Unrelated
    Commented Oct 1, 2020 at 23:12

3 Answers 3


On Catalina, running

sudo tmutil delete /path/to/foo.inProgress

returns error 22, but

sudo tmutil delete /path/to/foo.inProgress/*

aka deleting backups inside the inProgress folder, works for me.


I’ve never seen deletion happen faster than letting the next backup use or delete the files in that folder.

The next backup interval prunes and cleans this folder. If you have 24 hours of backups and still have a hung inProgress, I would open a case directly with Apple. There is a prune step before copying so hopefully you’re not in a total jam where it can not self rescue with enough time.

With hard links, it’s unlikely you are using any space on these files, since another interval already covers them or the next interval will reuse that space.

The risk of messing with the backups is you ruin that destination so unless you are willing to make that destination read-only and start backing up to a new destination, I would not mess with this manually - even to try to convince tmutil to delete that non-interval.

I have had great success using time machine utility to delete whole backups and letting the system run to pre-clean and post-clean these progress folders. When the progress folder remains for more than a day of successful backups, you usually have another problem and poking at a system with one failure isn’t likely to address the main problem. You could also try to bypass and clean up a large file if that helps you get space back if deleting intervals doesn’t prune enough space.


Regarding the Invalid deletion target (error 22): I've found that one might need to add the terminal app to the list of apps with Full Disk Access, available through System preferences > Security & Privacy > Privacy > Full Disk Access.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .