the process accountsd is using more than 300 % of my CPU. The error messages in the console that appear are:

  • AMSAccountStoreCache: [AF547297] An ACAccountStore has no associated media type. Returning the default media type for the current process. accountStore = AMSAccountStoreCache | defaultMediaType = com.apple.AppleMediaServices.accountmediatype.itunes
  • "Cannot check access to a private account type: com.apple.account.AppleAccount"

What I already tried from other questions:

  • Remove Mail accounts
  • Remove calendar accounts
  • Stop Spotlight from indexing your HDD
  • Kill AppleSpell and delete Spelling folder

Still the same error. Any ideas? Thanks!

  • I tried to remove the whole keychain and restart without any help. Now the following error appears as well in the console: ACAccount: [9CB59699] Failed to decrypt an account property. key = accountFlags | value = { } | value.class = __NSDictionary0 The last new things I did on the mac was installing PyCharm and WebStorm but it already ran for about 2-3 days
    – Sandro_V
    Commented Sep 29, 2020 at 5:23
  • I did the latest update and now it is working again.
    – Sandro_V
    Commented Sep 30, 2020 at 7:41

1 Answer 1


I also tried some things, like removing keychain with a UUID name, but that did not work. For me signing out of iCloud account solved the 300% CPU of accountsd.

Not the answer you're looking for? Browse other questions tagged .