4

Internet Recovery fails. USB Boot fails. Target mode won't mount.

Macbook Air 2019 TrueTone, ran before I deleted the SSD (stupid). Battery shot, requires power supply to run.

  1. Tried Internet Recovery with CMD-R, OPT-CMD-R, SHFT-OPT-CMD-R. All run download with progress (about an hour), then remain at full progress bar for days until I shut down. Reset PRAM. Tried various Internet, including Gigabit speed. 20 tries or more, occasional dropped Internet error -2003F on lousy WiFi.

  2. USB boot defaults to Internet Recovery. USB Drive is recognized, chosen, goes directly to Internet Recovery. Created several USB boots with several sticks and several apps, including manual w/ Terminal. Chose various erase formats (GUID, etc). Chose several OS installers (Catalina, Mojave). Latest USB stick with Mojave boots older 2014 iMac, but not the new Macbook.

  3. Will not mount in Target mode. Macbook displays target mode, but will not mount on iMac. Bought a new wire.

Beautiful, new, clean laptop, hardly used, left discharged for months, thus bad battery.

Can anyone think of anything else to try? Apple Store, maybe? Would they do anything I haven't? Does a dead battery affect these things?

1
  • 1
    I didn’t see you mention performing an SMC reset, which can help with power management issues as well as a large number of strange behaviors. Have you tried?
    – pion
    Mar 13, 2021 at 16:06

2 Answers 2

4

Call Apple or chat online with service would be my next step. Ask for a mail in repair if available and convenient. #3 is really unlikely to be anything easy if you have charged it for 2 to 4 hours.

Flat rate repairs for these are quite reasonable amd it would cover things like battery and or cpu board. Possibly under warranty or a program, worse case you get a quote for a professional battery repair.

A totally flat battery can drag the whole controller and board down. Hard to say until it’s in the shop with known good parts to test things out internally.

2
  • I'm pretty sure I can replace the battery, since I've done plenty of similar things, but I don't know how that would affect it. IT RAN before I erased the SSD.
    – Billbad
    Sep 28, 2020 at 15:35
  • 3
    I used to be certified to work on Apple, No way would I touch any glued battery on a Mac portable these days. YMMV if you’re not me, though.
    – bmike
    Sep 28, 2020 at 15:36
2

Ignore the answer you received above. Your Firmware is corrupted. You can easily fix this by doing DFU Mode

You will need another MacBook with a USB C Thunderbolt port. One is the host computer and the other is the Bricked computer (yours) you will have to restore it.

DFU mode will fix this computer issue IN Most cases. once you restore it from DFU, you will now be able to use internet recovery properly. BE WARNED though, your SSD will be wiped, and if you do not know your iCloud password you will not be able to restore your device (if it is locked to an icloud account).

Hope this helps!

YouTube Video to help you do it step by step https://www.youtube.com/watch?v=UaVgBP4gJsU

Also failed to mention: your MacBook Air 2019 has a two USB C ports. The port closest to the trackpad has to be used for DFU mode or it wont work.

3
  • Thank you! I have it ready to ship to Apple, but I will try this first.
    – Billbad
    Mar 13, 2021 at 19:31
  • It would be great if you added a link or a more detailed explanation of how to access DFU mode and what to do there. I only know DFU mode from iOS and am curious what you mean.
    – X_841
    Mar 13, 2021 at 20:26
  • Here is the link. I will update the comment with this link as well youtube.com/watch?v=UaVgBP4gJsU Mar 14, 2021 at 17:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .