1

I have a Numbers spreadsheet that I have previously setup to use Collaboration with my wife. A few weeks ago, as I was editing the spreadsheet on my Mac, Numbers told me that it couldn't connect to iCloud, and any changes I make won't be shared. I figured it was a temporary issue and would fix itself.

Last week the issue still wasn't fixed. When I open the spreadsheet on my iPad, everything is fine - it connects to iCloud and changes are uploaded. I tried creating a new spreadsheet and sharing it with my wife (I chose Messages as the sharing option), but after pressing the Share button, Numbers displays an error: "Sorry, your invitation couldn't be sent." If I use the "Copy Link" option, it also displays an error ("Sorry, people couldn't be added."). It works fine to share a spreadsheet from my iPad.

I thought maybe creating a new spreadsheet and sharing it from my iPad would fix the problems, but on my Mac Numbers still can't connect to iCloud.

During this time, any spreadsheets that aren't shared work fine - I can edit them on my Mac, and the changes show up on my iPad.

Rebooting my Mac hasn't helped.

Today I tried logging out of iCloud on my Mac and logging back in, but the problem persists.

Do you have any ideas how to fix this? I'm sure if I did a clean install that would fix this, but I'd like to avoid that if at all possible.

1
  • I’m assuming it’s your Mac and you need to make a new user account or remove all the iCloud setup, but let’s make sure the web apps work first. I’d hade to have you do the work if the problem is server side. – bmike Sep 27 '20 at 13:01
0

The easiest way to fix this is to use the web app. (To triage and also buy time to sort out the failure)

Both you and your collaborator should sign in to https://www.icloud.com/numbers

This way, there can’t be any issues with local passwords, local version issues, account problems. Once you’re signed in to the servers at Apple data centers, you can open up your document and be sure the sharing is saved and live online.

Then track back one by one to isolate an issue on a specific device or specific local version of numbers.

Once you confirm the issue is the local user account you may need to remove your account and start over to test things further. It’s less likely a system issue, but erase install everything can sometimes work without needing to remove the iCloud keys from the keychain and re-establish identity on that Mac user account.

AppleCare might have insight if they can read the precise error message on server side and compare with your account error.

4
  • I created a new spreadsheet using Numbers in my web browser, and setup collaboration with my wife. I made some edits, and they showed up on both my Mac and iPad. I closed iCloud in my browser (and logged out, not sure if that matters), and opened the spreadsheet in Numbers on my Mac. When I opened it I got the same couldn't connect error. – Andy Sep 27 '20 at 13:15
  • That’s a great first step. Do you have good backup of your Mac? @Andy I’m going to say you can go the upgrade route or work with Apple support. They know all the ways people mess this up and can enable debug if needed. – bmike Sep 27 '20 at 13:17
  • I do have good backups, but if I can fix my current install I'd prefer that instead of setting up from scratch. Sounds like calling Apple is my next step, then. Thanks for the debugging help. – Andy Sep 27 '20 at 13:21
  • Deleting your user account on the Mac then making a new account and signing in to iCloud is the next step I take. I need to be sure I have a full backup since when that works, you have migrate back the non-iCloud stuff. Or if you have massive iCloud photos, you might sync back in stages. – bmike Sep 27 '20 at 13:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .