1

In order to fix my problem I started my MacBookPro in Internet Recovery Mode, then I tried to create again the partitions/volumes using Disk Utility and I tried through the Terminal too, but so far I didn't have luck.

I'm getting this error when I try to install macOS: error message: target volume failed

I leave here the result of diskutil list. (If you need more information, please let me know to update this post.)

enter image description here enter image description here

Thank you so much for your time <3

PS: Sorry for my English. It isn't my mother language.

0

Only the first disk shown in your pictures, (internal), is "real". (synthesized) is how your Mac will see the real drive once it's complete, but you can ignore this one for now. All the others (disk image) are made by Internet Recovery as temporary structures, part of your recovery install & will vanish once you are booted normally.

What looks to have happened is you have formatted your internal drive, but not added a volume, only the APFS container.

The 'quick fix' would seem to be to format it again from Disk Utility. Set the View menu to 'Show all devices' first, then select your actual physical drive, not anything within it [you will see devices & their contents as a set of hierarchical folders in this View, so choose the top level] & use the 'Erase' function.
Choose GUID/APFS.

It should then make a new EFI and a new Container Disk, containing one Volume, named as you set in the previous dialog. That should now be ready to accept your install.

| improve this answer | |
  • I followed each step that you listed but it didn't work. This is so far what I have on Disk Utility: screenshots – alonsocn Sep 29 at 1:53
  • That's exactly what you should have. It worked. What happens when you install to that? – Tetsujin Sep 29 at 7:05
  • I got the same error. "Downloading installer information to the target volume failed." – alonsocn Sep 29 at 19:37
  • That usually happens when the installer file is corrupt, but sometimes if it's the "wrong" installer. Reformatting usually fixes it. Try again, using two different startup key combos. Test Cmd/Opt/R which should try to install the latest OS you can run. If no joy, try Cmd/OptShift/R which should try to install the oldest it can run [this 2nd try will likely need you to reformat again to HFS rather than APFS] – Tetsujin Sep 30 at 6:44
  • 1
    Thank you so much for your time @Tetsujin. I was able to repair it using a USB Installer! Again, thank you! – alonsocn Oct 4 at 18:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .