3

I logged out of my Macbook (pro 2019, Catalina) then after mistyping my password, accidentally hit the “recover password” button (or something along those lines, can’t remember). I do remember my password, so that’s not the issue.

My Macbook then rebooted and took me to a black screen with a grey lock and a password prompt (which I learned was the firmware password page). I don’t remember ever setting a firmware password.

I tried my regular login password, which didn’t work. I also tried any other password I could think of. None worked. I tried booting into recovery mode with command+r, but I still get the same screen.

I think the issue could be that my Macbook is trying to boot into recovery mode (because I accidentally clicked to recover my password), but recovery mode requires the firmware password. And now I can’t get it to boot normally, without recovery mode. I tried following these steps, but I always get the lockscreen.

Is there a way to go back to how it was before, with the normal login screen (with my known password)?

3
  • 1
    Sure. Provide proof of ownership to Apple and they will remove the firmware lock. Commented Sep 26, 2020 at 14:21
  • This is a company device, so I can always contact IT. Problem is, we’re all working remotely, and it’s the holidays where I live, so it should take a few days. In the meantime, I’m stuck without a computer. I was hoping there could be a simple way to undo this. I’ve never been asked for a firmware password before accidentally clicking recovery, so it seems like it would be possible...
    – ldmat
    Commented Sep 26, 2020 at 14:27
  • 1
    What would the point of the lock be if you could easily defeat it? Commented Sep 26, 2020 at 14:29

2 Answers 2

2

As you have already attempted the known ways of changing startup disk, it seems that the firmware password is necessary in order to proceed. However, there's no publically known way of bypassing the firmware password.

You can however take the device to an Apple Store along with proof of ownership, and they will unlock the firmware password for you. If you do not live near an Apple Store, call Apple and they can probably arrange mail-in repair or similar.

If it is a company device and you haven't got proof of ownership, you'll need to go through your employer. Most probably they will know the firmware password, and can proceed without having to contact Apple.

In some cases, managed devices (i.e. company issued laptops) can be set to require special access in order to do things that could circumvent managed device restrictions - such as for example trying to boot from a different partition. This could quite possibly be what you have run into. In this case you'll need to contact your employer to get it fixed.

0

This workaround is applied to my MacBook Pro 2018 Intel chip.

Turn off the device by pressing the power button and start again then access the terminal to enter the following commands.

# check to see if a firmware password is set, which is most likely enabled
sudo firmwarepasswd -check

# delete/disable password; this action will require restart
sudo firmwarepasswd -delete

The firmware password was removed, and there was no need to visit any MAC service point support center just to unlock the firmware password or have someone access your MAC device logic board. You may now access any start-up options without having to provide a firmware password or enter a strange padlock mode.

If you would like to set a firmware password on your device for whatever reason, simply enter the following commands. However, keep in mind that you will be requested to input the password if you are entering any start-up modes, so be sure to store it somewhere safe for easy access. Your usual login password will be useless here.

# set a new firmware password
sudo firmwarepasswd -setpasswd

# check if firmware password is set
sudo firmwarepasswd -check

# verify the firmware password
sudo firmwarepasswd -verify

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .