4

I've just bought Numbers and I'm trying to open some XLS files. They're in Excel '97 format, not encrypted, and with no password set. However, when I try to open them, I get this error message:

"The document is encrypted and can't be opened"

They open fine in openoffice. How do I open them in Numbers?

  • Are you sure that the file isn't corrupted? Can you regenerate or get it from source again? – Robin Feb 13 '12 at 16:26
  • Did you try to same them from OpenOffice into .xls again and then open them in Numbers? – nohillside Feb 13 '12 at 17:15
  • @Robin - yes, I'm sure there's nothing wrong with the files. – Simon Feb 13 '12 at 17:32
  • @Patrix - yes. I've even tried saving as an ODS, then opening that ODS and re-saving as an XLS. Still no good. – Simon Feb 13 '12 at 17:33
4

Sometimes a xls file don't have password to open it, but it has it to avoid modifying certain fields, you can validate that. Also, if you have access to a PC with Windows you can try to save your xls file in a newer format.

Another alternative is to use a program like parallels or VMware to install/emulate window on your Mac.

  • I think you're right about it having a protected field. However I don't have access to Windows or a newer version of Excel - I need to make this work in Numbers. – Simon Feb 13 '12 at 17:33
  • If the xls has a protected field, then Numbers wont open the file and it would show the "The document is encrypted and can't be opened" message. Don't know if there is a hack or something like that, but I read on an Apple forum about this constrain. – Paul N Feb 13 '12 at 18:03
  • OK - where do I file a bug? That's a stupid error message if the problem is that Numbers doesn't support encrypted fields – Simon Feb 15 '12 at 10:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .