I've been trying to get Perian to work in Lion, basically QuickTime simply refuse to play any files other than the standard QuickTime supported file types (Perian is supposed to add this functionality).

I tried uninstalling Perian and installing it again, but doesn't seem to be working. From a quick google search it seems that so many people has this problem, and some of them seems to get this working again by reinstalling but I didn't. Anyone got any ideas how to fix this?

It looks like a widespread problem. Tried following all those tips without luck. Maybe someone can tell me which things to delete in /Library/QuickTime?

Edit: I found the ticket(http://trac.perian.org/ticket/622) and the developer says that this is not Perian bug and they won't fixed it.

  • It has always worked for me whats your version. mine is 1.2.3
    – markhunte
    Commented Feb 13, 2012 at 19:01
  • Mine's 1.2.3 too. I'll update the question with some google results more relevant to me. Commented Feb 13, 2012 at 23:14
  • Have you tried deleting the cache in /Users/your_user/Library/Caches/org.perian.Perian. It's just a shot in the dark, nothing more. Commented Feb 15, 2012 at 5:54

2 Answers 2


Another shot in the dark...but this page suggests downgrading to Perian 1.2.2 on Lion (see "Solution 1").

The latest version 1.2.3 of Perian doesn't work on Mac OS X Lion. So if you have a Mac running Mac OS X 10.7, say, Lion, you have to downgrade the previous version, say 1.2.2. The version of 1.2.3 of Perian does not support QuickTime 10 in Lion and fails to fix the loss of audio after one second in xvid files with ac3. So if you have a Mac with Lion, converting video to QuickTime is highly recommended.

However, that particular page is all about how to play AVI files with Quicktime, so it may not work, but might be worth a try?

  • OK, this magically works. However it's such a pain looking for perian 1.2.2. I couldn't found it and I'm asking the developers in the IRC channel. What I did was I looked at my time machine backup and found 1.1.3. So far, it works okay. I've unticked "automatically update" and hopefully the developers are aware of this issue. Commented Mar 9, 2012 at 9:30

There is a proper workaround without downgrading into earlier version. We're supposed to remove the following files:

/Library/QuickTime/xViD 1.0 Pref App
/Library/QuickTime/XviD_Codec 1.0 alpha.component

Sigh.. Why can't they just put those path in here... All they said was:

Please consider removing obsolete QuickTime Components: FFusion, Xvid Delegate, 3ivX, DivX, DivX Decoder, XviD, msmpeg4v1, msmpeg4v2, AviImporter, EX_M4S2, Casio AVI Importer, AC3 Codec, and MatroskaQT.

That isn't enough information for the users!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .