I recently upgraded to macOS Big Sur developer Beta 8, when I do brew install jenv I get the error Homebrew: Your CLT does not support macOS 11.0. I am using CommandLine tools GM version. Tried to reinstall it couple of times, nothing worked so far. Here is the complete error

Error: Your CLT does not support macOS 11.0.
It is either outdated or was modified.
Please update your CLT or delete it if no updates are available.
Error: An exception occurred within a child process:
  SystemExit: exit

5 Answers 5


Simplest solution that worked when upgrading to Big Sur. A clean install may not require the solution below. There is inconsistency with the way CLT is upgraded to 12.2.

sudo rm -rf /Library/Developer/CommandLineTools
sudo xcode-select --install

Worked with the following versions (post-install)

❯ /usr/bin/xcodebuild -version
Xcode 12.2
Build version 12B45b

❯ pkgutil --pkg-info=com.apple.pkg.CLTools_Executables
package-id: com.apple.pkg.CLTools_Executables
volume: /
location: /
install-time: 1605632122
groups: com.apple.FindSystemFiles.pkg-group

Big Sur
11.0.1 (20B29)

  • After doing this, I was able to brew upgrade ruby-build --fetch-HEAD.
    – Zubin
    Commented Nov 16, 2020 at 10:55
  • Perfect, only solution I could find elsewhere - Fixed brew with: Upgraded: gradle 6.7 -> 6.7.1 jenkins 2.266 -> 2.267 node 15.2.0 -> 15.2.1 imagemagick 7.0.10-38 -> 7.0.10-39
    – NOTiFY
    Commented Nov 18, 2020 at 11:44
  • Warning to anyone doing this on a slow connection. I did the rm and then sudo xcode-select --install and it began downloading software with "5 hours 15 minutes remaining". Be careful if you're on a slow connection like me before embarking on this (I have not found a solution, still waiting) Commented Jun 3, 2021 at 5:43

We can fix this by downloading Command Line Tools for Xcode 12.3 from Apple website

  • 2
    It's probably worth noting that in order to download the package directly from Apple's website, one needs to be a member of Apple Developer Program. Commented Mar 16, 2021 at 10:10

Currently Brew is being updated incrementally to support MacOS Big Sur. You can follow the progress in the corresponding GitHub issue.

There is very little breakage in the core for Big Sur on intel and most of the work is to get core features working on the pre-release Apple Silicon hardware. Most people on Intel hardware and not the DTK should be ready now during beta or very soon after release of the initial version of the OS.

  • Excellent resource - please roll back my edit if it’s too cautious.
    – bmike
    Commented Oct 13, 2020 at 22:42
  • 1
    The referenced git issue is about Apple Silicon, not macOS 11. Commented Nov 14, 2020 at 17:37

Xcode is installed?

If you installed the Command Line Tools (CLT) and later installed Xcode, make sure the CLT installed beforehand are removed [sudo] rm -rf /Library/Developer/CommandLineTools and inside Xcode preferences Locations the CLT is set to Xcode.

There is no need to install any beta version if you have the newest Xcode installed.

Version 12.2 (12B45b)


I wanted to add, that the homebrew project has a tool to tell you how to fix Xcode tools related errors. Not all errors by "doctor" need to be fixed, but the ones relating to xcode-select and softwareupdate will fix tools issues on supported versions.

For the window while an OS is in pre-release and released-but-not-yet-supported, you will have to resort to answers like the ones here to manually fix the automated setup process.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .