0

I've been using/learning iMovie in order to create online classes for my students because of COVID19. Everything has been working fine until this morning.

iMovie just won't export a file.

I've created and exported about 30 videos thus far and I understand the basics. But now, when I select all the clips in a project and select the "Share - File..." option and hit "OK", nothing happens. No error messages, nothing. The little pie-chart progress indicator flashes for a fraction of a second before disappearing for good. The application doesn't bug or freeze (as I can keep working on the video or move to other projects), it just doesn't export the file.

I also can't export any of the videos it previously exported in the last few days and weeks. Nor will it export and brand new video.

I tried deleting the preferences: didn't solve anything.

I'm on 10.13 and iMovie 10.1.6 (and I can't upgrade).

Thanks.

P.S. The only change I made to the computer since yesterday is that I installed iOS 14 on my ipod touch. I had to use the MobileDeviceUpdater in order for iTunes to recognize my ipod touch. I can't imagine why it would change anything for iMovie, but nothing else changed.

5
  • 1
    I wonder if it is running out of disk space or you have a poisoned cache? I would check disk space and use a cleaner program like Onyx. The other thing would be to check console.app for anything with "imovie" in it. Sometimes lack of errors just means lack of visible errors. there might be something in a log somewhere and console.app could find that for you. – Steve Chambers Sep 22 '20 at 14:17
  • You were right: there was an error: "The operation couldn’t be completed. (com.apple.Compressor.CompressorKit.ErrorDomain error -1.)" – Nisaea Sep 22 '20 at 14:26
  • Try booting into Safe Mode (which clears out cache files & other oddities) and see if the exports work as expected. – IconDaemon Sep 22 '20 at 15:34
  • I tried. Sadly it didn't help. – Nisaea Sep 22 '20 at 17:33
  • 1
    I found the solution. For those interested, you'll find it in this Apple Discussion thread: discussions.apple.com/thread/251828217 – Nisaea Sep 22 '20 at 18:20
0

Try closing and reopening iMove, then export again. This worked for me.

1
  • Welcome on AD: have look at the Tour: apple.stackexchange.com/tour Although the OP doesnt clearly state it, it seems very likely he has tried to close and reopen iMovie. Therefore this does not seem to me like a useful answer. – X_841 Dec 27 '20 at 11:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .