Development gives iOS app(.ipa file) to test. I am able to install the app to iOS devices(iPad 6th generation and iPhone Xr with iOS 13) using iTunes. After installation app is launching, but when i connect the device to internet, app not launching.

Tried few fixes

  1. Settings > General > iPhone/iPad Storage > Uninstalled the app

  2. Settings > iCloud > disabled iCloud backup and iCloud Drive

Tried re-installing the app, but issue continues.

I am using iTunes in Windows OS, as i don't have macOS hardware. Appreciate any help to solve the issue

  • 1
    Great work testing - you have found a very proper issue with the app. It’s not ready for release yet, back to the developers for a bug fix build.
    – bmike
    Sep 22, 2020 at 11:29

1 Answer 1


So to summarize, the app ipa is on the iOS device and you need more logs from iOS.

TestFlight is the solution to this sort of problem since it enables telemetry to the developer that you can’t get using iTunes or macOS Finder.

Tell the developer the app doesn’t launch when connected to the internet and to send a new build. Their code signing is being rejected. One reason could be your test device isn’t enrolled for non-production code entitlements. Since you don’t have a Mac, Xcode can’t help you read the specifics from your device. In this case, they should use TestFlight so that you don’t have to mess with these easily preventable failures and make it easier for them to collect failures from your test devices (IMO).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .