1

Today I plugged in my external hard drive to back up to Time Machine, but it won't mount. I open up Disk Utility, run First Aid, and am greeted with a message that says "First Aid found corruption that needs to be repaired." When I click Show Details, the last few lines are:

Load and verify Logical Volumes B-Trees 
Unable to bootstrap transaction group 282114: incorrect block type 
No valid commit checkpoint found
The volume 04890072-B347-41EB-AB08-87EC029276D8 was found corrupt and needs to be repaired
Storage system check exit code is 1.
Problems were found with the partition map which might prevent booting
Operation successful.

I see that the volume is corrupted, but is there a way to recover it?

I have tried mounting it through the terminal, ala diskutil mountDisk readOnly /dev/disk1, but am greeted with the message saying it failed to mount (I don't know what I was expecting xD). The drive is encrypted, so I did try diskutil cs unlockvolume 04890072-B347-41EB-AB08-87EC029276D8 -stdinpassphrase, but it tells me "04890072-B347-41EB-AB08-87EC029276D8 is not a CoreStorage Logical Volume UUID", even though it shows up on diskutil cs list ¯\_(ツ)_/¯.

So I guess I'm left with the option of diskutil repairDisk /dev/disk1, but before I say y on Repairing the partition map might erase disk1s1, proceed?, I'm wondering if there's anything else I can do. I know it's likely I'll just have to start fresh with my backups, and I suppose I don't really need the old backups. I guess it's good this happened now rather than when I needed to use them for a recovery.

4
  • In my profesional life as a Windows tech I have dealt with drives that HAD to be recovered. And whenever I have done that the disk repair tech said, "Oh I am so gad you didn't run check disk! It will make my job easier and possible." Diskutil on macOS is in the same class of disk repair utilities. In attempts to fix a drive it often puts data integrity in second place over fixing it. So if you do run "diskutil repair disk" realize that it may sacrifice necessary backups in the pursuit of fixing the disk. Then again Disk repair services can be expen$$ive. Just so you know. – Steve Chambers Sep 21 '20 at 23:35
  • 1
    I’ll go so far to say, Disk Utility and check disk are designed to restore a sane directory at the expense of deleting data (when push comes to shove). It’s our responsibility to back up files so these tools can patch together an approximation of a healthy filesystem - not restore every bit of data. Run them in report mode if you aren’t ready to lose data. Take a drive out of service until you’re sure you won’t pay for professional help. – bmike Sep 21 '20 at 23:41
  • Would that be the same as 'verifying' the disk (or running First Aid in Disk Utility)? Just wondering why that's the case, why it makes data recovery more difficult / impossible. – oldjohn Sep 21 '20 at 23:56
  • Verify just spends time to tell you what it would do, it doesn’t do anything. – bmike Sep 22 '20 at 1:11
2

You’ve got the classic dilemma.

How much would you pay to get your data back? If you allow fsck to “repair” the drive, it might repair the volume structure by removing references to legitimate files. But to learn that, you have to pay for data recovery.

You could say yes and let it repair - it’s often a small error and quickly resolved. But, with Time Machine - you could also wait weeks if there are hundreds of backup intervals of hundreds of thousands of files and Disk Utility chooses to check each and every one.

For sure - go get a new external and set up a new backup set. Or skip the problem entirely and just erase this disk and see if it’s fine with the next backup.

I’d make an estimate of your value of time / the data / getting a new drive. Good luck with your decision. There’s no “easy” answer since the trade offs are uncertain.

Here’s some relevant posts covering how many days it takes to copy files off a working drive...

4
  • I appreciate the response! It is a dilemma indeed, although I was more comfortable taking the risk knowing that I don't crucially need the older backups anyway (only need a current one, and before I tried repairing it I created a new Time Machine backup on a new external HD). I ran diskutil repairDisk /dev/disk1, but alas, it failed: The volume 04890072-B347-41EB-AB08-87EC029276D8 was found corrupt and can not be repaired. Anything else I could try? Would I run into this issue again if I reformatted it and used it again? Do you think the encryption played a role in the corruption? – oldjohn Sep 22 '20 at 0:02
  • Nothing comes to mind. After I had this failure twice, I concluded that I just keep two external drives. I alternate them every time it complains it’s been two weeks without the other drive. (Only one is connected at a time) then when one needs an erase, I don’t lose all my history.) And when they fill, I just put them on the shelf and label them. For a 256 SSD I back up to 1 TB or so and just keep moving forward... – bmike Sep 22 '20 at 0:38
  • Having two alternating drives is a good idea, I think I'll adopt that practice. Thank you for your help. Also just curious: do you only use Time Machine? Have you ever experimented with CCC or other alternatives? – oldjohn Sep 22 '20 at 0:59
  • Great follow up, @oldjohn I only use Time Machine personally. Work has some licenses of both products. I run caching servers at home and in the labs, so bootable backups aren’t valuable to me - Disk Utility and asr are good enough. I erase install all the time and migrate back from TM or target disk mode. I have the deepest respect for both SuperDuper! and Carbon Copy Cloner if you want a bootable solution, send them your money and enjoy their excellent product. – bmike Sep 22 '20 at 1:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .