2

I just installed the security update on a remote computer and can no longer access that computer via Apple Remote Desktop or Screen Sharing?

Luckily I had Teamviewer as a backup...

Anyone else notice/got any ideas how to fix this?

I tried cycling everything on and off a few times, restarts, etc. SSH is working OK.

It seems to be exclusively the security update 2020-004 that broke it...I haven't changed anything else, and it's worked all year. Another computer on the network also on 10.14.6 is working fine (since I haven't installed that update on it yet...nor will I until I can resolve this).

Thanks.

1
  • That article I linked is a bit dense, let me know if you need a specific command to try and self-rescue.
    – bmike
    Sep 22 '20 at 1:04
1

No, we are not seeing that. Having ssh is key, you can log in and kickstart the ARD and self rescue most of the time. With command line access, you can also turn off remote access and turn it back on via ssh.

Once you get ARD or physical hands on the Mac, I would reinstall Mojave from the App Store to be sure the OS is installed cleanly on top of your existing apps and user files if you can’t suss out what happened.

5
  • I tried the kickstart and that didn't work...I'll mess with it some more tomorrow...in the meantime I installed RealVNC, and that is working OK; so at least I have a backup in case Teamviewer fails me (which it has done very occasionally)...on another note this same update has messed up the App Store on my home Mac, can't install updates via App Store here.
    – MTrope
    Sep 22 '20 at 2:09
  • ...can't create a new user, or enable root, or update via App Store on same remote Mac...it's definitely the update has damaged something.
    – MTrope
    Sep 22 '20 at 2:20
  • Oh, I also tried a safe boot and restart via SSH, never did that before, it was a Safe Boot as Teamviewer never came online and only had SSH...didn't help either...tried Disk Utility First Aid earlier also...now trying a Filevault encrypt/decrypt (wacky one I know)...
    – MTrope
    Sep 22 '20 at 2:25
  • Filevault did nothing...
    – MTrope
    Sep 22 '20 at 3:12
  • FileVault will only complicate the boot process in my experience and not affect screen sharing function @MTrope
    – bmike
    Oct 17 at 11:26
0

Here's one little trick that helped...so, if I initiate a connection from Remote Desktop (on client), and while that hangs, I log out and then log in (on the server) using Teamviewer, the connection resolves! Not a fix of course, but may help someone...

1
  • Once you quit Remote Desktop on the client side and reopen it, you're back hanging...it seems to keep working until you quit Remote Desktop though...last thing in the world I want to do is go in to this place, confirmed Covid now...so maybe this workaround will help someone who ends up in the same pickle...
    – MTrope
    Sep 22 '20 at 3:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .