4

I am a photographer and recently switched to a full iPad Pro 2020 setup, so I can edit my pictures on the go. Since SD cards tend to fail, I would also like to use my iPad Pro to backup the cards to an external SSD drive. A simple copy/paste from one drive (SD) to another (SSD) via the iPad.

However, I noticed that after importing RAW and JPEG files from the SD card to the iPad internal memory, some of the files seemed corrupted: RAW files couldn't be read by Lightroom, and JPEG files were half black or grey.

A couple of days ago, the same thing happened in the other way round. I processed RAW files in Lightroom for iPad, and when copying the processed JPEG to the external SSD, and viewing them on my PC, about 10% of them were completely trashed:

enter image description here

So I made a test, that I hope can be reproduced by someone. I'd love to have some feedback or even a solution to this issue. It's really disappointing that the iPad can't handle a copy/paste without corrupting the files...

First, I took a sample picture and made 500 copies on the external SSD. To be sure they're all exact copies, I used PowerShell on Windows to check the file hash. As expected, they're all the same:

enter image description here

Then, I transferred the 500 copies to the iPad's internal storage, using the "Copy" and "Paste" function in the app Files.

I renamed the folder in which the pictures are, copied it and pasted it back to the external SSD.

Finally, with the SSD plugged to my PC, I checked the file hash of the 500 files copied from the iPad, and indeed, some of them are corrupted, as you can see below (take Test (613).png for instance):

enter image description here

enter image description here

I am using an iPad Pro 2020 12.9", with the latest iPadOS 14, and the native app Files to do the transfer. My external SSD is formatted in exFat. My PC is the latest Windows 10.

I also tried with other kinds of devices: SD cards, cameras, USB thumb sticks, external SSD, SD card readers, USB-C hubs, even changed the cables, that all work perfectly with my PC, and never failed me. It's really coming from the iPad.

After some research, I saw a lot of complaints (slow transfer speed, mainly) that seem to be linked to the format of the external drive, and the fact that iPadOS seems to prefer APFS file format. But APFS isn't an option for people like me, who are using a desktop PC. Plus, the format of my SD cards are set by my camera, in that case, exFAT.

Finally, though I can understand speed may vary depending on the format of the drive -- corrupting the files is something that shouldn't happen, no matter what format I'm using. Especially for something as basic as importing photographs from an SD card...

At this point I don't know what to do, every time I try to copy/paste something, some files get corrupted. I would be grateful if somebody could give me some pointers, perhaps a solution, or simply confirm the issue by reproducing my test somehow.

7
  • Just tried the same test after upgrading from iPadOS 13.7 to iPadOS 14, and the issue remains the same.
    – piko
    Sep 21 '20 at 9:54
  • 1
    I'm not sure how you'd go about troubleshooting what you have proven to be true so far, except to give APFS a try - Paragon do an APFS for Windows which I've never tried, but I have all of their 'other FS for Mac' apps & they tend to be good. They usually have a free trial you could evaluate.
    – Tetsujin
    Sep 21 '20 at 11:03
  • Thanks, Tetsujin! I'll give it a shot, I'm curious to see how it works with APFS. However, that won't solve the issue I have when copying the SD card's content, since my cameras only work with exFAT.
    – piko
    Sep 21 '20 at 11:53
  • Hmm… interesting. What camera? I've never known one that can use anything other than regular FAT32 [though I shoot Nikon & don't really know the others so well]. tbh, I was anticipating the issue would be at the 'copy back to external' stage rather than the copy from camera card.
    – Tetsujin
    Sep 21 '20 at 12:02
  • 2
    I'm using a Fujifilm X-T3. I think it's more a matter of which SD card you're using. Some work with exFAT and some with FAT32: partitionwizard.com/partitionmagic/sdhc-vs-sdxc.html
    – piko
    Sep 21 '20 at 12:46
-1

So, I have same issue. Turns out it’s fault of files app. I have corrupted files only when I try to copy from iPad. But there is a way, you can try FileBrowserGO app. Just drag folder from files and land it on disk in FileBrowserGO app. It works without any issues for me, and it’s way faster to!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .