I'm having the problem explained in this post: mac won't start after "sudo chown -R $(whoami) $(brew --prefix)/*" command.

The solution proposed is to reinstall the macOS, which I have done, but unfortunately, the Apple logo black screen is coming and nothing is happening post it.

When I try to erase the disk as explained here: https://support.apple.com/HT208496, Disk Utility displays this error:

enter image description here

My macOS version is Catalina.

  • 1
    The Apple logo is shown and then "nothing is happening", so the Mac just stays at the Apple logo?. Did you follow all steps required to reinstall the OS? Did you get through the recovery mode OK? Did you follow any all the steps from support.apple.com/en-nz/guide/mac-help/mchlp1599/10.15/mac/… ? Sep 21, 2020 at 10:44
  • @jaume The OP refers to that Q&A already
    – nohillside
    Sep 21, 2020 at 13:23
  • Tried reinstalling, Catalina got reinstalled but still system shows apple logo and is not booting post it Sep 22, 2020 at 3:40
  • @jaume I even tried verbose mode for opening and it shows multiple "amfi denying core dump for pid" messages Sep 22, 2020 at 3:42
  • 1
    Thanks @jaume I tried a different approach and it worked. I was unable to erase the disk coz it couldn't be unmounted and was also unable to unmount disk. Thus, I created a new partition from Macintosh HD and installed MacOS on the newly created partition and it worked. Thanks a lot! Dec 8, 2020 at 8:25

3 Answers 3


I believe you can only erase the partition if it is not the active system partition (i.e. where the MacOS booted is installed).

You must boot from the rescue partition before you can do this.


Problem: Unable to reboot the Mac due to issue listed above.
Solution: Backup and Reinstall MacOS

Problem: Unable to solve the problem because reinstalling MacOS doesn't happen correctly and completely
Solution: Erase your disk (Ensure backup before you erase the disk)

Problem: Need to Backup Data before erasing disk
Solution: https://tanishqdhangar.medium.com/reinstalling-macos-but-need-to-backup-to-google-drive-before-clearing-your-disk-824530101203

Problem: Unable to erase disk; Couldn't unmount disk
Solution: Create a new partition (not volume) and reinstall MacOS on the newly created partition. (Please do not do it if you are not sure what you are doing!!)

Disclaimer: Author does not claim the method and is not responsible for any ill happenings. Do it at your own risk. ;)

  • @jaume Thanks a lot for your help! Hope this answer is expressive enough for others to understand. Dec 9, 2020 at 8:38

Can you boot from external USB media? If so, use Disk Utility in Recovery to erase the internal volume and then reinstall a fresh copy of macOS onto that drive.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .