My CDMA iPhone 4 (model MC677LL) running iOS 5.0.1 (9A405) doesn't have any problems connecting to my Time Capsule's Wifi Network (firmware: 7.6.1), but most of the time, the connection doesn't seem to be of any use. The phone shows good signal strength, but attempts to use that connection- Mobile Safari, Tweetbot, syncing OmniFocus- mostly time out. Note: the connection will still work for laptops/desktops running OS X while the phone is having problems.

This used to happen before updating to iOS 5, fwiw.

The only other thing that might be of any use in diagnosing this is knowing that I also have an Airport Express (firmware 7.6.1) in the living room which joins the Time Capsule's network so I can AirPlay right to the stereo.

To fix this, I've tried:

  1. switching the connection's DNS server(s) between the Time Capsule ( and Google's DNS (,, plus switching the Time Capsule's DNS server(s) between the default for my ISP and Google.

  2. Forgetting the network on the phone

  3. Doing a hard reset on the phone

  4. Hitting "Renew Lease" on the connection through the Settings panel on the phone

  5. Switching the Time Capsule's wireless settings from a specific radio channel to automatic and back again

  6. Turning interference robustness on and off

Like I said, though, the problem isn't that I can't connect. The problem seems to be a level or two up from connecting, but I can't think of any way to diagnose that. I guess the next time I catch it happening, I can try opening a site in Mobile Safari using a known IP address, but where could I go from there?

I'd love to get some good recommendations for diagnosing this on a deep technical level, including suggestions for specific tools, or links to helpful walkthroughs.

2 Answers 2


Have you tried testing the connection coming straight from the modem? The only good way to really test this is by connecting a computer directly to the modem over ethernet and seeing what kind of connection you have.

Does Airplay work for you? If so, another reason why I think there's nothing wrong with the router. Have you done a hard restart of your modem. Try that first as it's the resist thing to do.

  • Whoops, I left that very important tidbit out- yes, the connection still works with computers running OS X.
    – Jim J
    Feb 13, 2012 at 0:37
  • I would try doing a complete software restore on the Time Capsule. If that doesn't work, take both the Time Capsule and your iPhone to the Apple Store. Maybe it's a faulty Time Capsule.
    – W Dyson
    Feb 13, 2012 at 14:23

Switched wireless security on the Time Capsule from WPA/WPA2 Personal to straight WPA2 4 days ago and haven't had this problem since.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .