I'm facing a little problem while taking a screenshot of an X11 window (using XQuartz - if there's something better out there, lemme know).

I tried everything:

  • Entire Screen
  • Window-Only
  • Selection

Even tried recording the screen, same results - the box I need to screenshot (the one on the right) is always white:

enter image description here

(Side note: In the pic above the window is not "focused" (selected), but even with the "focus" on it, nothing change - even tried using the XQuartz setting where it focus the window on mouseover.)

This is how it should be:

enter image description here

Any idea on what setting I might need to change, in order to get my screenshot to work properly?

Oh... Almost forgot, I'm running the last macOS Catalina update (10.15.6)

Thanks in advance.

I might've found a solution by setting the Output as low as "256 Colors"

This the result

enter image description here

Edit: Added a pic of how it should be. Edit 2: Added a possible solution.

  • 1
    Try xwd in an xterm.
    – lhf
    Feb 13, 2021 at 19:14

3 Answers 3


I use xwd to capture a screenshot in xwd format, then display the screenshot using xwud and take a screenshot of the latter:

  • place the X window on the main screen (it does not work for me on dual-screen setups)
  • Open an XQuartz terminal window
  • xwd -root -out screenshot.xwd
  • xwud -in screenshot.xwd
  • now take a regular screenshot of the xwd visualizer with any screen capture software

This system avoids the need for other tools to be installed and works directly with XQuartz.


This looks to me like a display profile mismatch - specifically the gamut curve would do this.

Open your macOS system preferences and search for "profile"

Display colors and calibration

I would change these around a bit and see if you can get the images you want from the Screenshot app. Specifically, choosing a different display profile or running the Display Calibrator Assistant to choose your specific values should help greatly.

If you’re sure macOS isn’t causing this, you’ll want to look at your Xorg or server preferences for color space if you need macOS to do the screen shots.

Alternatively you might try XScreenCapture, xwd or similar to capture the bits from X11 directly to an image file.

  • not works for me - screenshot colors still different that view colors Oct 12, 2021 at 10:15
  • OK - now it’s on to using X tools if you’re isolated macOS as not the cause @KamilKiełczewski
    – bmike
    Oct 12, 2021 at 12:03

Go to Preferences under the XQuartz menu and then click on Output. You'll see a pulldown for colors. Make sure its set to millions of colors. Then restart XQuartz.

  • Already tried that too, unfortunately same results...
    – EdwardKirk
    Sep 16, 2020 at 16:43
  • not works for me too :( Oct 12, 2021 at 10:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .