5

I am using a DS620slim for Time Machine backups. My Mac runs 10.15.6 and it completed backups a day ago without issue.

I've created a shared folder with a specific user and a disk space quota to prevent time machine from consuming all my NAS space.

I've now reached the point where the shared folder is near at its quota limit, however, TM does not appear to be deleting old backups. Instead, attempting to backup gives me this error:

enter image description here

Why aren't old backups getting deleted automatically?

This is the process used to limit space is the shared folder quota:

enter image description here

6
  • Can you edit this with a screen shot what process you used to limit space? Also, this could also just be the typical estimate size is off so split the difference by excluding files. Do you think you have 300 GB pending?
    – bmike
    Sep 15 '20 at 17:05
  • Thanks for the suggestion. Added screen shot used to limit space. I recently increased the space from 2 TB to 2.2 TB (shown in the screenshot) but the error remained. So there should even be enough space now, but I still don't understand why TM isn't deleting old backups which is a core feature.
    – emiller
    Sep 15 '20 at 17:22
  • I bet you have to create a separate volume for this to work - I had a similar issue with NETATALK and I guess that's at the bottom of the Synology.
    – user370793
    Sep 15 '20 at 21:18
  • @Andyroo, would you still expect these problems to be present if SMB was being used instead of AFP?
    – emiller
    Sep 15 '20 at 22:04
  • Well I thought it was AFP BUT I've just come across support.apple.com/en-us/HT202784#nas that says its TimeMachine over SMB now. It may be worth checking the version of SMB being used and making sure it follows Microsoft / Apple / Synology best practice (think its above V2.1 now). Other thoughts are max connections (they are shared across all protocols) and MTU size (jumbo frames off)
    – user370793
    Sep 15 '20 at 23:49
3
+50

For me it worked after I disabled the Recycle bin on the Shared Folder. When Time Machine tried to delete old backups it moved them to the Recycle bin instead which causes the Shared Folder to never decrease in size.

4
  • Woah. What’s a great thing to document. Glad it was easy on the NAS side!
    – bmike
    Nov 30 '21 at 18:24
  • I couldn't find a way to disable it, but I could find a way to empty it daily.
    – benwiggy
    Nov 30 '21 at 21:02
  • 1
    I could change it in the Control Panel -> Shared Folder. Then pick your shared folder and click on the Edit button. Under the tab General should be a checkbox "Enable Recycle bin" which you can disable.
    – Michel
    Dec 1 '21 at 20:04
  • This appears to have solved my problem as well (though I'm not sure if there could be other issues at play). But I feel pretty confident you have the right solution. I first emptied the Recycle Bin, then disabled the setting that only allows administrators to empty it. But to be even more sure that this won't be an issue I disabled the Recycle Bin altogether for this Shared Folder as you suggested. Note that I had to Empty the Recycle Bin before I disabled it – otherwise old Time Machine data got stuck in the Recycle Bin, as "Empty Recycle Bin" didn't do anything after it's disabled!
    – P A N
    Dec 2 '21 at 17:43
2

I would open a support ticket with synology. You have excellent details and perhaps they have a patch or better setup procedure for your specific version of macOS and storage software.

  • specifically ask them if you could be using a sparse bundle for storage and if they can automate compacting of that bundle

As for your existing backup date - since space is tight, I would manually clean up some old backups using command line tools. Check for sparsebundle files which optimize network traffic and also need to be compacted periodically if space gets tight.

As you delete a few old backups, you can watch how much space is cleared and then attempt a backup after each cleanup.

Lastly, if you think you have enough space and don’t agree with the estimate for needed space, exclude some large folders and/or system files temporarily from backup and attempt a more limited backup. Eventually if you exclude enough “space” you can often get a small backup to run. After successful backups, the automatic pruning is more vigorous in my experience. After a few hours of clean runs, reverse the exclusions and see if your intended coverage now works with your storage.

Don’t overlook using an inexpensive direct attached disk as well to get one clean backup to a new destination that will let you know the Mac data is good and the problem is only with the synology side or existing data.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .