1

TL;TR: Macbook 2012 can recognize other disks except one SSD. But that disk works ok in other pcs or external cage. How can I be sure what is the problem? Really is the disk? Is the sata cable? Is the board?

Long story with what I've tried so far

I have a macbook 2012 that was working with an SSD (WD green 240GB). It stops working suddenly. I then power on again the computer and there was an icon with a question mark.

Then I booted in recovery mode but the system did not recognize the disk.

I've replaced the SSD with an spare HDD and I was able to install the OS to the HDD as a temporary solution because I thought the disk failed. I plugged the SSD in another pc (iMac) and I was able to access all my files. fsck reported something like fsroot tree issue so I erased the disk.

I then removed the HDD from the macbook and was ready to install again my SSD. Again, disk was not recognized. I then tried again reading the SSD in another pc and it shows up.

I tried using an external case to install the OS but the installer does not allow me because of firmware or something like that. But at least the disk was recognized.

At this point I was not sure if it was the disk or if it was a cable issue. So I plug in another SSD and it was recognized correctly.

I take then my SSD WD green and clean its pins with an spry electronic cleaner. The macbook then recognized the disk. Then tried to erase the disk in order to make a fresh install of the OS but the erase tool hangs when saying something like "wating partitions to be ready". I waited long time and nothing happened.

I turn off the computer then and took again the disk to another pc. I ran SMART, short and long self tests on the disk and seems ok to me. Then I erase it with full of zeroes using dd tool on a freebsd machine.

I attached again the disk to the macbook I was able to at least start the OS installation... just that it never finished. It hangs with an apple and a full bar below the logo.

Turned off the mac again after waiting long long time and the disk was not recognized again... but guess what, if I attach the disk to another pc it shows up.

Again I tried with HDD and other SSD and macbook is ok recognizing them.

At the end I'm unsure about what the problem is... I cannot say is the SSD disk because it works on other machines. I cannot say is the SATA cable as different disks works ok attached to it.

I can use/buy another SSD disk on that mac but I'm not sure if the issue will appear again... that is, if replacing the disk will really fix the issue :)

Any hints? something I'm missing to try?

This is the SMART info of the disk: https://bsd.to/1KqT

  • I've installed a new firmware to the disk too. Tried to erase the disk before installing the OS on the mac... again it gets stuck on "Waiting for partitions to activate". I'm about to think due this intermittence that it's the sata cable. – Yaazkal Sep 15 at 17:27
  • If you have a USB case then try putting the SSD in that and format using security erase (lowest level only with the being a SSD). – Andyroo Sep 15 at 21:24
  • @Andyroo I've already tried that. Just that I've tried using the zero fill; the difference with the security erasing is that secure erase just fill it with random data. Do you think that after trying security erasing will it fix it? – Yaazkal Sep 15 at 22:37
  • The only advantage that I can see is that this destroys any boot sector data and clears any partition / super block data. If that does not help then gut feel is that it is the cable... – Andyroo Sep 15 at 23:32
  • @Andyroo well, that's exactly what I've done. Anyway I tried what you suggest and again same issue "Waiting for partitions to activate". I'll try ordering a new cable and see what happens. – Yaazkal Sep 16 at 12:41
2

It's the cable. The internal disk flex cable connecting the disk to the motherboard. Trust me, I have seen these symptoms dozens of times with the MacBook Pro 13" 2012, and it can really give extrmemly weird problems, of the sort you describe.

You need a new cable, the only problem is knowing which one. The 2012 MBPs use one of 3(!) different identical looking disk flex cables with different model numbers. First check which one you have, lift the connector from the motherboard and look on the underside of the cable on the part. The model number will probably be either 821-1480 or 821-2049. If it is the former it might need to be replaced either by the same, or the 821-2049. If the latter, it will need a replacement with the same model, 821-2049.

If you only get one new cable to try, I would bet on the 821-2049. Regardless, it's that cable, there's your problem right there.

| improve this answer | |
  • Thanks Lars. As I mention on a comment above now I feel is the cable as you suggest. Cable says 821-1480-a. I'll get exactly that in order to prevent any incompatibility. Let me order it, try it and I'll update as soon as I can. – Yaazkal Sep 16 at 12:40
  • 1
    Thanks ! It was effectively the cable. – Yaazkal Sep 20 at 21:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .