0

I am trying to redirect both my microphone and computer sound output to an aggregate device so I can auto-transcribe both sides of a web conference. I set up the Aggregate Device via the Audio Midi Setup and ensured that they both have the same sample rate. Then I record using sox and the playback sounds chopped up and slowed down. Is it interleaving the two streams as if they're alternating instead of simultaneous? I've tried using both Soundflower and Virtual Audio Cable--same results. Also same results whether "Drift Correction" is enabled or disabled, and whichever of the two inputs I set as Clock Source.

Has anyone encountered the same behavior? Is it possible to fix in the Midi Setup and/or is there any kind of workaround using sox itself?

Thank you!

1
  • This has always been tricky since Soundflower stopped including Soundflowerbed [that was the internal routing component]. I've never tried VAC. See apple.stackexchange.com/q/174136/85275 for a similar but not duplicate situation. One way to fix this for certain, but not for free, is Audio Hijack which can do both the routing & the recording. – Tetsujin Sep 15 '20 at 6:42

You must log in to answer this question.

Browse other questions tagged .