7

My Mac with macOS Mojave is setup to receive iMessages and that is all I want it to do. However, since I set it up, the Mac appears on the list of speaker choices when I answer a phone call.

enter image description here

The "Allow Calls on Other Devices" setting is off:

enter image description here

So how do I remove "Jeff's Mac" from my speaker list?

P.S. I am on iOS 14.0.1

P.P.S. I tried various things - the only thing that worked reliably was turning off Bluetooth on my mac.

2
  • It's not a "speaker" it's a device that you can use to take (and make) phone calls like a headset or your car's Bluetooth. If you have a mic and a speaker, which all Mac computers do, you can use it as a speaker phone. However, you're question isn't clear - you're asking how to remove it, which you already demonstrate how by disabling "Allow Calls..." What is the actual question then? Why it appears twice? – Allan Oct 20 '20 at 1:33
  • @Allan The question is how to remove the Mac from the speaker list entirely. I'll clean up the question to remove confusion. – AngryHacker Oct 20 '20 at 15:34
1

First off, it's not a "speaker list," it's list of devices that can take or make phone calls. If you paired a Bluetooth headset it would show up there as will your car's Bluetooth connection (if you have one and it's paired). This is probably what's causing your confusion when trying to disable it.

So, to do so, you have to turn off WiFi calling on your "other" devices

Settings → Phone → Calls on Other Devices. There will be a section called Allow Calls On. Toggle off the device you don't want to allow access, in this case "Jeffs Mac." Once you do that, it will no longer show up as a device to send the call to.

Below are screen grabs from my iPhone that's configured to use my Mac as an audio device for phone calls. Upon disabling it in Calls on Other Devices it's removed as an audio option on the call screen.

Phone Settings - Calls on Other Devices Phone Settings - Calls on Other Devices Page 2

4
  • So you are saying leave the Allow Calls on Other Devices option on, but turn off individual devices under Allow Calls On? – AngryHacker Oct 20 '20 at 16:46
  • You can turn it all off if you like. I took the granular route in case you or future readers wanted to remove just the computer but leave other devices like an iPad. Give it shot - both the single device and all devices. You're not going to harm anything. – Allan Oct 20 '20 at 17:22
  • I gave both approaches a shot previously based on some other threads I read. It worked temporarily - the device would come back on the list. Yesterday, I disabled Bluetooth on the device. So far, it hasn't come back on to the list. It's not a good solution but hopefully it works for now. – AngryHacker Oct 20 '20 at 18:27
  • I turned mine off since writing this and it hasn't come back. Try turning off just the single device (lower toggles) and leave "Allow Calls on Other Devices" on (the top toggle) – Allan Oct 20 '20 at 20:09
0

enter image description here

Doh! I already gave up this quest, but after a while I found that macBook's clipboard is being shared with my iPhone, so that I started looking for how to disable this, and found the option Allow Handoff between this Mac and your iCloud devices. As I turned it off, I thought, if it related to the speaker issue? And happily this was it.

3
  • Yes, Handoff will be the reason it copies/pastes and offers you to change "speaker" from phone to Mac. If you still want handoff from time to time, you can either reenable it (either on the Mac or on the iOS device) or simply disable bluetooth or wifi on one of the devices. Handoff requires either a bluetooth connection between the two devices or both devices being on the same wifi network. – AVelj Dec 22 '20 at 11:10
  • @AVelj not sure how it works, but I had Mac even if it was asleep, and far away from me to be reachable via bt/wifi. – std.denis Dec 23 '20 at 12:31
  • @AVelj I had no luck with removing Mac from the speakers with all other methods, but after switching Handoff I finally succeeded. Maybe it's not it, and this is just some cargo cult – Apple services malfunction are often enigmatic. – std.denis Dec 23 '20 at 12:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .