0

I'm using a Varmilo VA88m Nordic layout external keyboard for my macbook, I've been using it with relatively little problems until now when the < - key, and the ' - key have been swapped. I have not found any solution to this that works.

I tried the tip in the photo below, but this didn't cahnge anything, but now whenever i pres the "Change keyboard type" key in keyboard settings, it registers my external keyboard as my built in one.

enter image description here

Any ideas? Stuck for ages trying to figure it out, happened so suddenly and I am completely out of clues. Preferable any fixes that don't include Karabiner-Elements, tried it before and it only gave me more problems...

EDIT: This is the message i get when i try to use the "Change keyboard type" in settings :enter image description here

5
  • Did you get a resolution on this? Because I have the same problem. The <-key is now the §-key. When I look at System Preferences -> Keyboard -> Input Sources, the keyboard at first look like the ISO keyboard it's supposed to be but when I press the '§' key, the layout changes to a ANSI layout. – Erik Mar 25 at 20:56
  • Honestly not really, I currently don’t have the issue but it reappers at random times. Think the way i fixed it before was by re installing karabiner elements, but still the issue does come back. Still no luck woth a permanent fix. – Tobias Brambo Mar 27 at 0:18
  • I've been in contact with Varmilo and they've sent me a patch file. Haven't been able to apply it yet. – Erik Mar 29 at 9:00
  • And now I have and it worked. While I can share it with you, I'm not really certain that it will really work. – Erik Apr 7 at 17:31
  • Ah, my fix still works for now so I'm good. Good that it worked for you. – Tobias Brambo Apr 9 at 12:44

You must log in to answer this question.

Browse other questions tagged .