5

In macOS Catalina, ambient noise reduction is applied by default to audio of an external source coming in through the headphone jack. This is not always desired, e.g. when recording musical instruments. In previous versions of macOS, noise reduction could be disabled via System Preferences. However, this option is not present in Catalina. This thread proposes downgrading to Mojave as a solution to the problem (which it is), though this is not desirable for me as I need Catalina for other reasons.

As mentioned in the thread, Apple's audio documentation specifies that ambient noise reduction is disabled if a 4-channel built-in microphone format is selected in Audio MIDI Setup. Unfortunately, my external audio source only supports 2 channels, so this option is unavailable in Audio MIDI Setup.

My guess is that the solution is any of the following:

  1. Some terminal command to disable ambient noise reduction entirely.
  2. Modifying some plist, e.g. in /Library/Preferences/Audio/.

However, I have not yet managed to find a solution, and would greatly appreciate it if anyone could think along. Thanks.

11
  • Perhaps using a USB mic, or a mic <> USB audio interface would bypass the ambient noise reduction. Blue Snowball mics connect directly to USB 2.x ports. Behringer makes some excellent interfaces. – IconDaemon Sep 12 '20 at 17:26
  • Definitely true, a Focusrite 4i4 is already present. Though I have a tiny 6.35 mm to 3.5 mm audio interface which I can bring along my MacBook very easily wherever I go for a quick recording session on the fly. Nothing fancy, but it does the job! Except for the noise reduction... ;-) – Thijmen Sep 12 '20 at 20:20
  • Does the following command in Terminal return anything? defaults read -g | grep -E '[A-F0-9]{8}_' – user3439894 Sep 13 '20 at 21:50
  • The reason I ask, is on a system running 10.13 if I toggle the checkbox for Use ambient noise reduction the ~/Library/Preferences/.GlobalPreferences.plist file sets 1/0 checked_/_unchecked on a key that's formatted as [A-F0-9]{8}_[0-9]{8}_[0-9]{8}_[A-F0-9]{8}_[A-F0-9]{8}, e.g. 646F6E7A_00000000_00000001_6E7A6361_696D6963 for the Internal Microphone Built-in. Testing with another external microphone the value of the last group of 8 characters changed in the plist file. Checking the Internal Microphone on two different Macs the keys were identical. – user3439894 Sep 13 '20 at 21:51
  • So, if you toggled the setting previously before upgrading to 10.15 maybe the key exists and you can use e.g. defaults write -g "646F6E7A_00000000_00000001_6E7A6361_696D6963" -int 0 to set it as unchecked. While I didn't need to use killall cfprefsd directly after the previous command under 10.13, you might need to under 10.15. If the key isn't there, you would have to boot the Mac from e.g. a USB drive running a earlier OS to get the key. This approach may not work in 10.15 but it's the only solution I can think of that might work. Good Luck! – user3439894 Sep 13 '20 at 21:51
0

Sometimes the best solution... is a little patience! I have recently updated to MacOS Big Sur (11.0.1), and the checkbox to disable ambient noise reduction is available again in the sound input settings.

However, there is a caveat: the toggle is available only to a subset of devices. Please note the following, stated on Apple's website:

Capture less background noise when using your computer’s built-in microphone: Select “Use ambient noise reduction”. This option does not appear if a 4-channel built-in microphone format is selected in Audio MIDI Setup or on Mac models with an Apple T2 chip.

Source: https://support.apple.com/en-ie/guide/mac-help/mchlp2567/mac

Big Sur Rules

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .