0

I'm struggling with some problem involved with enable dGPU AMD Radeon. To the needs of installation MacOS Catalina I had to disable discrete graphics card. I reboot into recovery mode and used command

nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00

after reboot I again run in recovery mode and wrote

csrtuil disable 

I was following this tutorial http://dosdude1.com/gpudisable/ (I could not run Single-User-Mode). It worked perfectly and installation Catalina went well. But after this I wasn't able to enable dGPU again. I tried to use key combination CMD+Option+R+P to reset NVRAM and 'nvram -c' in terminal but it didn't help. Also I tried to solve the problem following these guys explanation but it didn't have any effect. (First link, Second link). I was searching any information but I can not find the answear. Below I put picture from /System/Library/Extensions directory (maybe there is something wrong). I really appriciate any help! (Last week I upgraded this Macbook with SSD Crucial MX500 and Corsair 8 GB DDR3 1333Mhz but it probobly has no issues with this ) enter image description here enter image description here

4
  • Catalina is not officially supported on 2011 models. You're likely simply running into a hardware incompatibility, and is something you won't be able to fix. Sep 12 '20 at 21:50
  • I tried exectly the same on MacOS High Sierra and it didn't work.
    – Alex
    Sep 13 '20 at 8:47
  • You said you had to disable it for Catalina. How is High Sierra relevant? Did you have to disable it for High Sierra as well? You shouldn't have had to. High Sierra is officially supported on your model. What do you mean? Sep 13 '20 at 22:14
  • I mean that after disabling dGPU to the needs installion Catalina I tried enable this dGPU on Catalina, High Sierra, Lion (I have installed compatibile versions of MacOs). But on every system I have the same problem that I can't turn on AMD Radeon graphics card. I tried using commands "nvram -c" or "nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%00%00%00%00". I found some information that it helped some people with the same problem but it didn't work on my macbook.
    – Alex
    Sep 14 '20 at 23:05
1

After the steps below, I'm seeing again both graphics cards in "About This Mac" of my MacBookPro 17" Late 2011, running Catalina Patcher. See this image

  1. Shut down the computer. Plug in the power adapter to a power source if it's not already connected.
  2. Press Control+Option+Shift+Power keys to reset the SMC
  3. Boot and press Control+S immediately after you hear the startup sound. Then enter this command: nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%00%00%00%00
  4. Then type 'exit' to reboot.
  5. Then shut down again the computer.
  6. Boot and press and hold the Command+Option+P+R immediately after you hear the startup sound. Hold these keys until the computer restarts and you hear the startup sound for a second time.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .