I tried everything I could find on StackExchange and the internet, including the official apple-suggested approach of removing adding and removing the volume to privacy https://support.apple.com/en-us/HT201716 . This question sums up most of the things I tried Spotlight doesn't show applications also this answer https://apple.stackexchange.com/a/337782/146629

One thing many tutorials mention is that you should run sudo rm -rf ./Spotlight* or ./Spotlight-V100

However, I don't have it in root and I asked around friends with newest macOS and they did not find it in root either. I would like to give it a last shot and remove that index manually before I give up and try a system restore with Time Machine, but I can't seem to find the indices anywhere. Have they moved in recent versions? Any hints on how to make spotlight work again without system restore?

I'm on 10.15.6 (19G2021)

  • 3
    On macOS Catalina it's located at: /System/Volumes/Data/.Spotlight-V100 Sep 7, 2020 at 14:40

1 Answer 1


Just tested on a macOS Catalina 10.15.6 system, used the following command in Terminal to remove the .Spotlight-V100 directory:

sudo rm -r /System/Volumes/Data/.Spotlight-V100

It deleted the .Spotlight-V100 directory and in less than a minute recreated it and started indexing the system again.

  • Alright, can't say if this would help me, b/c I already did a time machine restore at this point to get it finally working, but I'll accept this answer, cause it's the first time I see someone writing a path on which I actually found the thing!
    – Ev0oD
    Sep 8, 2020 at 8:32
  • This continues to work in macOS monterey Feb 22, 2022 at 16:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .