2

Consider this PDF file for example. The text in this file appears scrambled when opened with Safari or Preview. However, the PDF is formatted fine when opened with Adobe Acrobat Reader DC or most 3rd party web browsers including but not limited to Gecko-based Firefox and Chromium-based Google Chrome, Microsoft Edge and Opera.

I wondered if it is because of some of the embedded fonts in the PDF file which perhaps I needed to install on my mac. So, I searched for these fonts and installed them on my system but to no avail. Perhaps it is a bug?

How would you deal with such PDF files when you want to primarily use Preview?


EDIT: I am using macOS Catalina 10.15.6 and Preview 11.0. In the attached screenshot, the left rendering is by Preview and the right one is by Adobe Acrobat Reader DC.

Comparison of Preview and Acrobat Reader DC

6
  • 1
    There is nothing wrong with your example PFD in either Safari or Preview on my system. You should probably add a screen shot of what you're seeing that's not right and also state explicitly what version of macOS you're running so we can compare properly. – user3439894 Sep 4 '20 at 21:17
  • @user3439894 Thanks. I hope the edit helps. – Nanashi No Gombe Sep 4 '20 at 21:49
  • I originally tested under macOS High Sierra, however, after testing on a clean build of macOS Catalina 10.15.6 I get the same results as you. – user3439894 Sep 4 '20 at 22:19
  • 1
    Working at a law firm where the preferred document format is PDF, we found that some PDFs, often that come from the same places, are just poorly distilled. And the only way to guarantee the document looks right every time is to use Adobe's Acrobat products. To this day I find PDFs that Preview can't handle but Acrobat renders perfectly. I don't have an answer just lots of experience... – Steve Chambers Sep 4 '20 at 23:14
  • Yes, testing this on Catalina produces the same result. Mojave renders it correctly. – benwiggy Sep 5 '20 at 8:23
3

The PDF does seem to display incorrectly on Catalina, but not on other versions of macOS.

Preflighting the PDF in Acrobat flags several instances of fonts that are not embedded. Acrobat and other versions of macOS seem to be able to substitute the system Arial and Times New Roman, but Catalina does not. I'd suggest that is the bug.

Exporting from Acrobat as PostScript and re-distilling will produce a PDF that works in Catalina.

Exporting from Preview in another version of macOS will also produce a version that works in Catalina. (Exporting, not just Save As..)

Ghostscript produces a single blank page when trying to process the PDF.

The file was originally created using Acrobat 3, in 2001 on some Windows OS. While such systems should have been creating perfectly decent PDFs, something seems to have gone wrong here.

3
  • Acrobat Reader DC does not seem to have an option to export the pdf as postscript. Other than trying the same from a different version of macOS, do you have any other way to redistill the pdf? – Nanashi No Gombe Sep 5 '20 at 11:49
  • You'll need some other application that can a) read it correctly and b) output new PDF or PostScript. You could try Save As PDF from the print menu of those browsers that display it correctly. – benwiggy Sep 5 '20 at 12:30
  • That helps. Thanks. – Nanashi No Gombe Sep 5 '20 at 13:14
0

Would like to propose a solution or at least an idea to give it a try:

If your issue is that text doesn't show when using the quick look preview of a pdf (the one that shows documents by pressing spacebar on a selected file no matter where in the system: emails, file browser, etc), make sure to check if there's anything weird on your 'Font Book'. Open that, go to all fonts, select them all, make sure to click on 'Download' if the option appears on the right side and it could also say that there are duplicates. I did it all in one shot but I think the duplicate fonts warning is what might have been the culprit.

Summary:

  1. Open Font Book app.
  2. Go to all fonts and select them all.
  3. Click Download if that option visibly appears on the UI (around the top right of the font book frame). Wait for it to finish.
  4. Resolve Duplicates (bottom right of the window frame). I chose the "resolve automatically" option.

This fixed it for me. Hope it helps.

EDIT: forgot to mention, regarding the question. That maybe this font fix might also help with the scrambling issue found. In my case the text was invisible but it was there, I could select it, copy it and paste it somewhere else to finally see it. The text scrambling sounds dangerously close to be fixable by the same steps.

Opinion: I know it's old but that's why it's great to not close threads (like Reddit does), I just managed to find a solution and had passed by this very same thread before (and many others some of which are sadly now closed).

1
  • I'm not convinced that's a general solution. You shouldn't need to download any of Apple's supplemental fonts to get a PDF to display properly. Resolving Duplicates might help, though 99.9% of all PDFs will have their fonts embedded. If the problem is only occurring in QuickLook, then it's likely a font cache issue. – benwiggy Apr 18 at 9:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .